summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2019-06-12 18:12:57 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-14 08:56:46 +0100
commitb16c6d0452c79dcc2fccc4a7b9b2d68d53d2b353 (patch)
tree6b18e1d7c4ede205437b21caa5120d7b93a87a3f /meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
parent275e5e7ecf4f79b7892ae35a47902188d9905bd0 (diff)
downloadopenembedded-core-contrib-b16c6d0452c79dcc2fccc4a7b9b2d68d53d2b353.tar.gz
mesa: Update 19.0.6 -> 19.1.0
Update all patches to apply on 19.1.0 version. See full mesa 19.0.1 changes here: - https://www.mesa3d.org/relnotes/19.1.0.html Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch')
-rw-r--r--meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch25
1 files changed, 13 insertions, 12 deletions
diff --git a/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch b/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
index dfc67b83d9..0064dc643c 100644
--- a/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
+++ b/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
@@ -1,7 +1,7 @@
-From 498f230c9446fc7a1b4dc77ff6b84ee1a3b53bf4 Mon Sep 17 00:00:00 2001
+From da6b9188f29942684d4262f0c6264d09bb6fe7de Mon Sep 17 00:00:00 2001
From: Fabio Berton <fabio.berton@ossystems.com.br>
-Date: Wed, 24 Apr 2019 17:01:24 -0300
-Subject: [PATCH] meson.build: check for all linux host_os combinations
+Date: Wed, 12 Jun 2019 13:40:20 -0300
+Subject: [PATCH 1/3] meson.build: check for all linux host_os combinations
Organization: O.S. Systems Software LTDA.
Make sure that we are also looking for our host_os combinations like
@@ -9,15 +9,16 @@ linux-musl etc. when assuming support for DRM/KMS.
Also delete a duplicate line.
+Upstream-Status: Pending
+
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
-Upstream-Status: Pending
---
meson.build | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
-index 53d02e31097..c41f6b4e402 100644
+index 8ab8a550f56..e11880f2902 100644
--- a/meson.build
+++ b/meson.build
@@ -34,6 +34,8 @@ cpp = meson.get_compiler('cpp')
@@ -29,16 +30,16 @@ index 53d02e31097..c41f6b4e402 100644
# Arguments for the preprocessor, put these in a separate array from the C and
# C++ (cpp in meson terminology) arguments since they need to be added to the
# default arguments for both C and C++.
-@@ -89,8 +91,6 @@ if (with_gles1 or with_gles2) and not with_opengl
- error('building OpenGL ES without OpenGL is not supported.')
- endif
+@@ -107,8 +109,6 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
+ # Only build shared_glapi if at least one OpenGL API is enabled
+ with_shared_glapi = get_option('shared-glapi') and with_any_opengl
-system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'dragonfly', 'linux'].contains(host_machine.system())
-
- _drivers = get_option('dri-drivers')
- if _drivers.contains('auto')
+ dri_drivers = get_option('dri-drivers')
+ if dri_drivers.contains('auto')
if system_has_kms_drm
-@@ -792,7 +792,7 @@ if cc.compiles('int foo(void) __attribute__((__noreturn__));',
+@@ -836,7 +836,7 @@ if cc.compiles('int foo(void) __attribute__((__noreturn__));',
endif
# TODO: this is very incomplete
@@ -48,5 +49,5 @@ index 53d02e31097..c41f6b4e402 100644
endif
--
-2.21.0
+2.22.0