summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mx
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2012-02-08 13:29:50 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-10 13:36:56 +0000
commitfe2c13684e2a0b652007e92a6f11942c6366483e (patch)
tree358ca066d09dd913ebf0df11724a7f423f3b2935 /meta/recipes-graphics/mx
parent84d62181f80402fa461675e03b20ba08da1991e8 (diff)
downloadopenembedded-core-contrib-fe2c13684e2a0b652007e92a6f11942c6366483e.tar.gz
mx: ensure gettext and dbus are present
Upstream informs me that D-bus isn't really optional as it's required to make some of the API work such as the single instance MxApplication. Therefore ensure we're building with it enabled. Gettext macros are used in the configure.ac so inherit gettext to ensure the required dependencies are present. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/mx')
-rw-r--r--meta/recipes-graphics/mx/mx_1.4.2.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-graphics/mx/mx_1.4.2.bb b/meta/recipes-graphics/mx/mx_1.4.2.bb
index 91eca2960f..c50bc0f986 100644
--- a/meta/recipes-graphics/mx/mx_1.4.2.bb
+++ b/meta/recipes-graphics/mx/mx_1.4.2.bb
@@ -1,9 +1,11 @@
DESCRIPTION = "Clutter based widget library"
LICENSE = "LGPLv2.1"
-DEPENDS = "clutter-1.8"
+PR = "r1"
-inherit autotools
+DEPENDS = "clutter-1.8 dbus-glib"
+
+inherit autotools gettext
SRC_URI = "http://source.clutter-project.org/sources/mx/1.4/mx-${PV}.tar.bz2 \
file://introspection-m4.patch"
@@ -14,5 +16,5 @@ SRC_URI[sha256sum] = "9d40dd48a8e3d098cc75c05163f77305ffb83439783dc91be50681c950
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24 \
file://mx/mx-widget.c;beginline=8;endline=20;md5=13bba3c973a72414a701e1e87b5ee879"
-EXTRA_OECONF = "--disable-introspection --disable-gtk-widgets"
+EXTRA_OECONF = "--disable-introspection --disable-gtk-widgets --with-dbus"