summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-04-29 15:37:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-29 22:29:19 +0100
commit2edf7a19598e10326603603dfa00ab91c9327e2d (patch)
tree19a4ef14e08108766b1a3612cd9df2e8c891286a /meta/recipes-graphics/piglit
parent37dc4ad4a87fb9042dc3e9bb389cedc8b5acadf7 (diff)
downloadopenembedded-core-contrib-2edf7a19598e10326603603dfa00ab91c9327e2d.tar.gz
piglit: support build piglit without x11
* test PIGLIT_BUILD_GL_TESTS depend on glx library, so depend on x11, so respect the DISTRO_FEATURES, only enable it when x11 is enabled. * mesa-demos depend on libGL.so which is provide by recipe mesa, but when x11 is disabled, libGL.so is not generated. so we can only rdepend on this when x11 is enabled * add x11 PACKAGECONFIG to add correct config/depend/rdepend [YOCTO #6077] Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/piglit')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 59d134801a..b6542a191c 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -17,11 +17,12 @@ PV = "1.0+gitr${SRCPV}"
S = "${WORKDIR}/git"
-DEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
+X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
+X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
+
+DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
inherit cmake pkgconfig python3native distro_features_check bash-completion
-# depends on virtual/libx11
-REQUIRED_DISTRO_FEATURES = "x11"
# depends on virtual/libgl
REQUIRED_DISTRO_FEATURES += "opengl"
@@ -32,8 +33,10 @@ REQUIRED_DISTRO_FEATURES += "opengl"
export TEMP = "${B}/temp/"
do_compile[dirs] =+ "${B}/temp/"
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
+PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
+
do_configure_prepend() {
if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
@@ -48,7 +51,7 @@ RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
python3-misc \
python3-unixadmin python3-xml python3-multiprocessing \
python3-six python3-shell python3-io \
- python3-netserver mesa-demos bash \
+ python3-netserver bash \
"
INSANE_SKIP_${PN} += "dev-so already-stripped"