summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-01-24 18:07:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-29 15:59:33 +0000
commit1fb9e706ba83df272ca924d8ea65460bb5675aa8 (patch)
tree7655192c0a959cf2f7d7af46fd3008ba50927d05 /meta/recipes-graphics
parent94cea2b5f3091de0326c4d7322b45de2ce9fae3b (diff)
downloadopenembedded-core-contrib-1fb9e706ba83df272ca924d8ea65460bb5675aa8.tar.gz
shaderc: avoid reproducible issues
Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/shaderc/shaderc_2020.4.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta/recipes-graphics/shaderc/shaderc_2020.4.bb b/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
index ee9b118371..e886e81d0e 100644
--- a/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
+++ b/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
@@ -19,15 +19,17 @@ DEPENDS = "spirv-tools glslang"
EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DSHADERC_SKIP_TESTS=ON"
+BBCLASSEXTEND = "native nativesdk"
+
+# TODO: probably there is better solution for this.
+# I don't know any method for get the version of a receipe in DEPENDS,
+# so do this ugly hack
+inherit pkgconfig
+DEPENDS += "glslang-native"
do_configure_prepend() {
- # TODO: probably there is better solution for this.
- # I dont know any method for get the version of a receipe in DEPENDS
- # so do this ugly hack
cat <<- EOF > ${S}/glslc/src/build-version.inc
"${PV}\\n"
"$(pkg-config --modversion SPIRV-Tools)\\n"
"$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n"
EOF
}
-
-BBCLASSEXTEND = "native nativesdk"