summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-01-24 18:07:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-29 15:59:33 +0000
commit3355367f339c36161aced3e9fcbc38bca7915ada (patch)
treee7b55cd7110c583cb28b48e296bec6bd2926da92 /meta/recipes-graphics
parent6ddba144e1aa9288645ec4b7271fc4138ef945ba (diff)
downloadopenembedded-core-contrib-3355367f339c36161aced3e9fcbc38bca7915ada.tar.gz
glslang: enable shared libs
Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/glslang/glslang_11.1.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glslang/glslang_11.1.0.bb b/meta/recipes-graphics/glslang/glslang_11.1.0.bb
index f1cc966b2a..5e53f02b1c 100644
--- a/meta/recipes-graphics/glslang/glslang_11.1.0.bb
+++ b/meta/recipes-graphics/glslang/glslang_11.1.0.bb
@@ -15,4 +15,14 @@ S = "${WORKDIR}/git"
inherit cmake python3native
+EXTRA_OECMAKE = " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=ON \
+ -DENABLE_CTEST=OFF \
+ -DBUILD_EXTERNAL=OFF \
+"
+
+SOLIBSDEV = "glslang.so"
+FILES_${PN} += "${libdir}/*.so"
+
BBCLASSEXTEND = "native nativesdk"