summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-26 10:27:22 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-30 13:57:17 +0000
commit6fbec0f12a4083341ae2bd3de05f66196bbf5327 (patch)
treeb11e43e8bddead3e44fdfbf47713e5a327bfcb5f /meta/recipes-graphics
parentbf2c7f82f07509424ce25ed5f64a03d7e4723fd1 (diff)
downloadopenembedded-core-contrib-6fbec0f12a4083341ae2bd3de05f66196bbf5327.tar.gz
piglit: update to latest revision
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/piglit/piglit/0001-render-ops.c-add-missing-format-string.patch24
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb3
2 files changed, 26 insertions, 1 deletions
diff --git a/meta/recipes-graphics/piglit/piglit/0001-render-ops.c-add-missing-format-string.patch b/meta/recipes-graphics/piglit/piglit/0001-render-ops.c-add-missing-format-string.patch
new file mode 100644
index 0000000000..261d98d8f6
--- /dev/null
+++ b/meta/recipes-graphics/piglit/piglit/0001-render-ops.c-add-missing-format-string.patch
@@ -0,0 +1,24 @@
+From e21e68f6aa0f5249fce613e8fd4ac0edbd5cb7b0 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 22 Dec 2020 13:35:11 +0100
+Subject: [PATCH] render-ops.c: add missing format string
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ tests/spec/ati_fragment_shader/render-ops.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/spec/ati_fragment_shader/render-ops.c b/tests/spec/ati_fragment_shader/render-ops.c
+index 131334ba2..19a353d67 100644
+--- a/tests/spec/ati_fragment_shader/render-ops.c
++++ b/tests/spec/ati_fragment_shader/render-ops.c
+@@ -393,7 +393,7 @@ piglit_display(void)
+ bool ok = piglit_probe_rect_halves_equal_rgba(get_test_x(i), get_test_y(i),
+ w * 2, h);
+ enum piglit_result sub_result = ok ? PIGLIT_PASS : PIGLIT_FAIL;
+- piglit_report_subtest_result(sub_result, test->name);
++ piglit_report_subtest_result(sub_result, "%s", test->name);
+ piglit_merge_result(&result, sub_result);
+ }
+
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 31954aa8b6..442c1a3c62 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -13,10 +13,11 @@ SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
file://0001-serializer.py-make-.gz-files-reproducible.patch \
file://0001-framework-profile.py-make-test-lists-reproducible.patch \
file://0001-tests-shader.py-sort-the-file-list-before-working-on.patch \
+ file://0001-render-ops.c-add-missing-format-string.patch \
"
UPSTREAM_CHECK_COMMITS = "1"
-SRCREV = "0fda9f67a782edec640998286e7b6058e8933d17"
+SRCREV = "603deba4ab66e2a8948693a14d715e536caddcc5"
# (when PV goes above 1.0 remove the trailing r)
PV = "1.0+gitr${SRCPV}"