summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-01-24 18:26:45 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-29 15:59:33 +0000
commit97cab6b9691497841b2ae894e25f83d893c2ee30 (patch)
treea5380a05288737c0310bdd7c6f2131bd42ea12c7 /meta/recipes-graphics
parent0f7aa28a254ab25e3c3f6322d750e765518fb8b5 (diff)
downloadopenembedded-core-contrib-97cab6b9691497841b2ae894e25f83d893c2ee30.tar.gz
spirv-tools: cleanup
- spirv-headers is provived in a separete receipe, so add it as dependencie - add a new package spirv-tools-lesspipe that needs bash - remove unneeded external sources Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/spir/spirv-tools_2020.6.bb31
1 files changed, 10 insertions, 21 deletions
diff --git a/meta/recipes-graphics/spir/spirv-tools_2020.6.bb b/meta/recipes-graphics/spir/spirv-tools_2020.6.bb
index eb07833f22..2c855d8d8e 100644
--- a/meta/recipes-graphics/spir/spirv-tools_2020.6.bb
+++ b/meta/recipes-graphics/spir/spirv-tools_2020.6.bb
@@ -2,37 +2,26 @@ SUMMARY = "The SPIR-V Tools project provides an API and commands for \
processing SPIR-V modules"
DESCRIPTION = "The project includes an assembler, binary module parser, \
disassembler, validator, and optimizer for SPIR-V."
+SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SECTION = "graphics"
+SRCREV = "b27b1afd12d05bf238ac7368bb49de73cd620a8e"
+SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git"
+UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
S = "${WORKDIR}/git"
-DEST_DIR = "${S}/external"
-SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;name=spirv-tools \
- git://github.com/KhronosGroup/SPIRV-Headers.git;name=spirv-headers;destsuffix=${DEST_DIR}/spirv-headers \
- git://github.com/google/effcee.git;name=effcee;destsuffix=${DEST_DIR}/effcee \
- git://github.com/google/re2.git;name=re2;destsuffix=${DEST_DIR}/re2 \
- git://github.com/google/googletest.git;name=googletest;destsuffix=${DEST_DIR}/googletest \
- file://0001-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-file.patch;destsuffix=${DEST_DIR}/effcee \
-"
-SRCREV_spirv-tools = "b27b1afd12d05bf238ac7368bb49de73cd620a8e"
-SRCREV_spirv-headers = "f027d53ded7e230e008d37c8b47ede7cd308e19d"
-SRCREV_effcee = "cd25ec17e9382f99a895b9ef53ff3c277464d07d"
-SRCREV_re2 = "5bd613749fd530b576b890283bfb6bc6ea6246cb"
-SRCREV_googletest = "f2fb48c3b3d79a75a88a99fba6576b25d42ec528"
inherit cmake python3native
-EXTRA_OECMAKE += "-DSPIRV_WERROR=OFF"
+DEPENDS = "spirv-headers"
-do_install_append() {
- install -d ${D}/${includedir}/spirv
- install -m 0644 ${DEST_DIR}/spirv-headers/include/spirv/1.2/* ${D}${includedir}/spirv
- install -d ${D}/${includedir}/spirv/unified1
- install -m 0644 ${DEST_DIR}/spirv-headers/include/spirv/unified1/* ${D}${includedir}/spirv/unified1
-}
+EXTRA_OECMAKE += "-DSPIRV-Headers_SOURCE_DIR=${STAGING_EXECPREFIXDIR}"
FILES_SOLIBSDEV = ""
FILES_${PN} += "${libdir}/*.so"
+PACKAGES =+ "${PN}-lesspipe"
+FILES_${PN}-lesspipe = "${base_bindir}/spirv-lesspipe.sh"
+RDEPENDS_${PN}-lesspipe += "${PN} bash"
+
BBCLASSEXTEND = "native nativesdk"