summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2020-12-19 00:34:21 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-20 00:03:01 +0000
commitacf78fd3d03e4fe07ee4ad677f178d17dc10ac7b (patch)
treed2ddc681d6f24a5603feb13c09487904d43e0a31 /meta/recipes-graphics
parentb97a18f45ad5166aa3532768c50c0d0b3c952011 (diff)
downloadopenembedded-core-contrib-acf78fd3d03e4fe07ee4ad677f178d17dc10ac7b.tar.gz
mesa.inc: switch true/enabled false/disabled
A number of options have been switched from true/false to enabled/disabled and the older usage is deprecated, as is seen in the configuration logs: ../mesa-20.3.1/meson.build:92: WARNING: gles1 option "true" deprecated, please use "enabled" instead. ../mesa-20.3.1/meson.build:100: WARNING: gles2 option "true" deprecated, please use "enabled" instead. ../mesa-20.3.1/meson.build:119: WARNING: shared-glapi option "true" deprecated, please use "enabled" instead. ../mesa-20.3.1/meson.build:381: WARNING: gbm option "true" deprecated, please use "enabled" instead. ../mesa-20.3.1/meson.build:412: WARNING: egl option "true" deprecated, please use "enabled" instead. ../mesa-20.3.1/meson.build:493: WARNING: dri3 option "false" deprecated, please use "disabled" instead. ../mesa-20.3.1/meson.build:516: WARNING: gallium-vdpau option "false" deprecated, please use "disabled" instead. ../mesa-20.3.1/meson.build:570: WARNING: gallium-xvmc option "false" deprecated, please use "disabled" instead. ../mesa-20.3.1/meson.build:691: WARNING: gallium-va option "false" deprecated, please use "disabled" instead. ../mesa-20.3.1/meson.build:727: WARNING: gallium-xa option "false" deprecated, please use "disabled" instead. Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/mesa.inc22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index dba23f586f..011abe6e95 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -77,7 +77,7 @@ def check_buildtype(d):
MESON_BUILDTYPE = "${@check_buildtype(d)}"
EXTRA_OEMESON = " \
- -Dshared-glapi=true \
+ -Dshared-glapi=enabled \
-Dgallium-opencl=disabled \
-Dglx-read-only-text=true \
-Dplatforms='${@",".join("${PLATFORMS}".split())}' \
@@ -98,13 +98,13 @@ PACKAGECONFIG_class-nativesdk ?= "gbm dri egl opengl elf-tls x11"
PACKAGECONFIG_remove_libc-musl = "elf-tls"
# "gbm" requires "dri", "opengl"
-PACKAGECONFIG[gbm] = "-Dgbm=true,-Dgbm=false"
+PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled"
X11_DEPS = "xorgproto virtual/libx11 libxext libxxf86vm libxdamage libxfixes xrandr"
# "x11" requires "opengl"
PACKAGECONFIG[x11] = ",-Dglx=disabled,${X11_DEPS}"
PACKAGECONFIG[elf-tls] = "-Delf-tls=true, -Delf-tls=false"
-PACKAGECONFIG[xvmc] = "-Dgallium-xvmc=true,-Dgallium-xvmc=false,libxvmc"
+PACKAGECONFIG[xvmc] = "-Dgallium-xvmc=enabled,-Dgallium-xvmc=disabled,libxvmc"
PACKAGECONFIG[wayland] = ",,wayland-native wayland libdrm wayland-protocols"
DRIDRIVERS_class-native = "swrast"
@@ -113,7 +113,7 @@ DRIDRIVERS_append_x86_class-target = ",r100,r200,nouveau,i965,i915"
DRIDRIVERS_append_x86-64_class-target = ",r100,r200,nouveau,i965,i915"
# "dri" requires "opengl"
PACKAGECONFIG[dri] = "-Ddri-drivers=${@strip_comma('${DRIDRIVERS}')}, -Ddri-drivers='', xorgproto libdrm"
-PACKAGECONFIG[dri3] = "-Ddri3=true, -Ddri3=false, xorgproto libxshmfence"
+PACKAGECONFIG[dri3] = "-Ddri3=enabled, -Ddri3=disabled, xorgproto libxshmfence"
# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
@@ -126,10 +126,10 @@ PACKAGECONFIG[vulkan] = "-Dvulkan-drivers=${@strip_comma('${VULKAN_DRIVERS}')},
PACKAGECONFIG[opengl] = "-Dopengl=true, -Dopengl=false"
# "gles" requires "opengl"
-PACKAGECONFIG[gles] = "-Dgles1=true -Dgles2=true, -Dgles1=false -Dgles2=false"
+PACKAGECONFIG[gles] = "-Dgles1=enabled -Dgles2=enabled, -Dgles1=disabled -Dgles2=disabled"
# "egl" requires "dri", "opengl"
-PACKAGECONFIG[egl] = "-Degl=true, -Degl=false"
+PACKAGECONFIG[egl] = "-Degl=enabled, -Degl=disabled"
PACKAGECONFIG[etnaviv] = ""
PACKAGECONFIG[freedreno] = ""
@@ -159,12 +159,12 @@ GALLIUMDRIVERS_append = "${@bb.utils.contains('PACKAGECONFIG', 'r600', ',r600',
GALLIUMDRIVERS_append = "${@bb.utils.contains('PACKAGECONFIG', 'virgl', ',virgl', '', d)}"
PACKAGECONFIG[gallium] = "-Dgallium-drivers=${@strip_comma('${GALLIUMDRIVERS}')}, -Dgallium-drivers=''"
-PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true, -Dllvm=false, llvm${MESA_LLVM_RELEASE} llvm-native \
+PACKAGECONFIG[gallium-llvm] = "-Dllvm=enabled -Dshared-llvm=enabled, -Dllvm=disabled, llvm${MESA_LLVM_RELEASE} llvm-native \
elfutils"
-PACKAGECONFIG[xa] = "-Dgallium-xa=true, -Dgallium-xa=false"
-PACKAGECONFIG[va] = "-Dgallium-va=true,-Dgallium-va=false,libva-initial"
+PACKAGECONFIG[xa] = "-Dgallium-xa=enabled, -Dgallium-xa=disabled"
+PACKAGECONFIG[va] = "-Dgallium-va=enabled,-Dgallium-va=disabled,libva-initial"
-PACKAGECONFIG[vdpau] = "-Dgallium-vdpau=true,-Dgallium-vdpau=false,libvdpau"
+PACKAGECONFIG[vdpau] = "-Dgallium-vdpau=enabled,-Dgallium-vdpau=disabled,libvdpau"
PACKAGECONFIG[lima] = ""
GALLIUMDRIVERS_append ="${@bb.utils.contains('PACKAGECONFIG', 'lima', ',lima', '', d)}"
@@ -175,7 +175,7 @@ GALLIUMDRIVERS_append ="${@bb.utils.contains('PACKAGECONFIG', 'panfrost', ',panf
OSMESA = "${@bb.utils.contains('PACKAGECONFIG', 'gallium', 'gallium', 'classic', d)}"
PACKAGECONFIG[osmesa] = "-Dosmesa=${OSMESA},-Dosmesa=none"
-PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
+PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
# llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2)
FULL_OPTIMIZATION_append = " -fno-omit-frame-pointer"