summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-03-12 13:53:06 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-16 08:48:04 +0000
commit0edd68ee0672656ba60ed7c8d9cea3baa39328db (patch)
tree09715a70b666b0230bad11adc707b947dff10ec0 /meta
parent8a34826558b5a0f2a4463f7d7bb230f1473b6621 (diff)
downloadopenembedded-core-contrib-0edd68ee0672656ba60ed7c8d9cea3baa39328db.tar.gz
python3-ply: move from meta-python
Dependency for python3-cryptography Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-ply_3.11.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-ply_3.11.bb b/meta/recipes-devtools/python/python3-ply_3.11.bb
new file mode 100644
index 0000000000..99c037bb73
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-ply_3.11.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python Lex and Yacc"
+DESCRIPTION = "Python ply: PLY is yet another implementation of lex and yacc for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/ply"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://README.md;beginline=5;endline=32;md5=f5ee5c355c0e6719c787a71b8f0fa96c"
+
+SRC_URI[md5sum] = "6465f602e656455affcd7c5734c638f8"
+SRC_URI[sha256sum] = "00c7c1aaa88358b9c765b6d3000c6eec0ba42abca5351b095321aef446081da3"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN}:class-target += "\
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native"