summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-08-20 11:08:34 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-09-03 18:30:16 -0700
commit162c652a2ca36e5afc58f21cb86601a057a4e4bc (patch)
tree13ea22035b2190cea36e798dcc91fe12fcbfc67f /meta
parent1fb94b77f833e612cbd75e71ac21e434c8cd9c56 (diff)
downloadopenembedded-core-contrib-162c652a2ca36e5afc58f21cb86601a057a4e4bc.tar.gz
libzypp: add new package
Signed-off-by: Saul Wold <saul.wold@intel.com> Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/libzypp/libzypp/no-doc.patch31
-rw-r--r--meta/recipes-extended/libzypp/libzypp/rpm5.patch30
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb22
3 files changed, 83 insertions, 0 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp/no-doc.patch b/meta/recipes-extended/libzypp/libzypp/no-doc.patch
new file mode 100644
index 0000000000..3928980e51
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/no-doc.patch
@@ -0,0 +1,31 @@
+not building doc (doxygen based)
+
+8/19/2010 - created by Qing He <qing.he@intel.com>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0629b1f..41746cc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -110,13 +110,6 @@ FIND_PACKAGE(EXPAT REQUIRED)
+ FIND_PACKAGE(OpenSSL REQUIRED)
+ FIND_PACKAGE(Udev REQUIRED)
+
+-FIND_PROGRAM( DOXYGEN doxygen )
+-IF ( NOT DOXYGEN )
+- MESSAGE( FATAL_ERROR "doxygen not found: install doxygen to build the documentation." )
+-ELSE ( NOT DOXYGEN )
+- MESSAGE( STATUS "doxygen found: ${DOXYGEN}" )
+-ENDIF ( NOT DOXYGEN )
+-
+ MESSAGE(STATUS "soname: ${LIBZYPP_VERSION_INFO}")
+ MESSAGE(STATUS "version: ${VERSION}")
+
+@@ -154,7 +147,7 @@ ADD_SUBDIRECTORY( devel EXCLUDE_FROM_ALL )
+ ADD_SUBDIRECTORY( tools )
+ ADD_SUBDIRECTORY( examples )
+ ADD_SUBDIRECTORY( po EXCLUDE_FROM_ALL )
+-ADD_SUBDIRECTORY( doc )
++#ADD_SUBDIRECTORY( doc )
+ ADD_SUBDIRECTORY( vendor )
+ ADD_SUBDIRECTORY( tests EXCLUDE_FROM_ALL )
+
diff --git a/meta/recipes-extended/libzypp/libzypp/rpm5.patch b/meta/recipes-extended/libzypp/libzypp/rpm5.patch
new file mode 100644
index 0000000000..b86463dc54
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/rpm5.patch
@@ -0,0 +1,30 @@
+build fix for rpm5
+
+8/19/2010 - created by Qing He <qing.he@intel.com>
+
+diff --git a/zypp/target/rpm/BinHeader.cc b/zypp/target/rpm/BinHeader.cc
+index e9ad382..86a9c96 100644
+--- a/zypp/target/rpm/BinHeader.cc
++++ b/zypp/target/rpm/BinHeader.cc
+@@ -19,7 +19,7 @@ extern "C"
+
+ #ifndef _RPM_4_4_COMPAT
+ #ifdef _RPM_5
+-typedef rpmuint32_t rpm_count_t;
++typedef uint32_t rpm_count_t;
+ #else
+ typedef int32_t rpm_count_t;
+ #endif
+diff --git a/zypp/target/rpm/librpmDb.cv3.cc b/zypp/target/rpm/librpmDb.cv3.cc
+index bf18e45..5454ea9 100644
+--- a/zypp/target/rpm/librpmDb.cv3.cc
++++ b/zypp/target/rpm/librpmDb.cv3.cc
+@@ -14,7 +14,7 @@ extern "C"
+ {
+ #ifndef _RPM_4_4_COMPAT
+ #ifdef _RPM_5
+-typedef rpmuint32_t rpm_count_t;
++typedef uint32_t rpm_count_t;
+ #else
+ typedef int32_t rpm_count_t;
+ #endif
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
new file mode 100644
index 0000000000..61a140050d
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -0,0 +1,22 @@
+HOMEPAGE = "http://en.opensue.org/Portal:Libzypp"
+DESCRIPTION = "The ZYpp Linux Software management framework"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=11fccc94d26293d78cb4996cb17e5fa7"
+
+inherit cmake
+
+DEPENDS = "rpm boost gettext curl libxml2 zlib sat-solver expat openssl udev"
+
+S = "${WORKDIR}/git"
+PV = "0.0-git${SRCPV}"
+PR = "r0"
+
+SRCREV = "4494797d5b0369365b1af63921de45b197ead64f"
+
+SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
+ file://no-doc.patch \
+ file://rpm5.patch"
+
+FILES_${PN} += "${libdir}/zypp ${datadir}/zypp ${datadir}/icons"
+FILES_${PN}-dev += "${datadir}/cmake"