summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-03-12 12:59:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-16 08:44:46 +0000
commit6786ea8f0d70c7ff0fea353032d78db353628798 (patch)
tree21682860ef044cc274402f0224fa2621499d73b9 /meta
parent27bd134c899d00d93806ecb0a62ec3f30b1e6ec6 (diff)
downloadopenembedded-core-contrib-6786ea8f0d70c7ff0fea353032d78db353628798.tar.gz
python3-pytest-subtests: move from meta-python
Dependency for python3-cryptography ptest. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-pytest-subtests_0.6.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest-subtests_0.6.0.bb b/meta/recipes-devtools/python/python3-pytest-subtests_0.6.0.bb
new file mode 100644
index 0000000000..5e4847b8d9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytest-subtests_0.6.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "unittest subTest() support and subtests fixture."
+DESCRIPTION = "Adds support for TestCase.subTest.\
+New subtests fixture, providing similar functionality for pure pytest tests."
+HOMEPAGE = "https://github.com/pytest-dev/pytest-subtests"
+BUGTRACKER = "https://github.com/pytest-dev/pytest-subtests/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
+
+SRC_URI[sha256sum] = "3ebd306a8dcf75133f1742f288c82f36426ebcf8a132d4ee89782d20e84fc13a"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"