summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-03-12 13:35:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-16 08:48:04 +0000
commit78106bc12b995bbb42e02f2e5d8fbc56d917b934 (patch)
tree5e5557dbcf6fd3c7165ed9a96468da9e0b62f391 /meta
parented53e6728704ac77f15fe266a63b453ba1a2a846 (diff)
downloadopenembedded-core-contrib-78106bc12b995bbb42e02f2e5d8fbc56d917b934.tar.gz
python3-iso8601: move from meta-python
Dependency for python3-cryptography Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-iso8601_1.0.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-iso8601_1.0.2.bb b/meta/recipes-devtools/python/python3-iso8601_1.0.2.bb
new file mode 100644
index 0000000000..aabc47d69b
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-iso8601_1.0.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Simple module to parse ISO 8601 dates"
+HOMEPAGE = "http://pyiso8601.readthedocs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844"
+
+SRC_URI[sha256sum] = "27f503220e6845d9db954fb212b95b0362d8b7e6c1b2326a87061c3de93594b1"
+
+inherit pypi poetry_core
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"