summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-02-06 22:53:13 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-08 14:19:33 +0000
commit991f8617b9ca9680b3f81cb215e3b39095260e7c (patch)
tree7f0654203d9dccabba59f4f3ab053ac000e61534 /meta
parent99132e1163dd32168be3d02d27ce056b27f948b2 (diff)
downloadopenembedded-core-contrib-991f8617b9ca9680b3f81cb215e3b39095260e7c.tar.gz
python3-numpy: update 1.22.1 -> 1.22.2
Replace an ad hoc fix via patch with an upstream one. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-numpy/0001-numpy-core-setup.py-disable-svml-for-now.patch29
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.22.2.bb (renamed from meta/recipes-devtools/python/python3-numpy_1.22.1.bb)7
2 files changed, 5 insertions, 31 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy/0001-numpy-core-setup.py-disable-svml-for-now.patch b/meta/recipes-devtools/python/python3-numpy/0001-numpy-core-setup.py-disable-svml-for-now.patch
deleted file mode 100644
index 66e322116a..0000000000
--- a/meta/recipes-devtools/python/python3-numpy/0001-numpy-core-setup.py-disable-svml-for-now.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 0f0601e79f9ce7614d157284523e6cd8af2259d5 Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex@linutronix.de>
-Date: Wed, 5 Jan 2022 12:12:47 +0100
-Subject: [PATCH] numpy/core/setup.py: disable svml for now
-
-The check really doesn't work in cross compiling,
-as it is using host python to see what arch we're
-building on. Issue reported upstream:
-https://github.com/numpy/numpy/issues/20736
-
-Upstream-Status: Inappropriate [needs upstream fix]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- numpy/core/setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/numpy/core/setup.py b/numpy/core/setup.py
-index a5f423d..945f2dd 100644
---- a/numpy/core/setup.py
-+++ b/numpy/core/setup.py
-@@ -70,7 +70,7 @@ def can_link_svml():
- """
- machine = platform.machine()
- system = platform.system()
-- return "x86_64" in machine and system == "Linux"
-+ return False
-
- def check_svml_submodule(svmlpath):
- if not os.path.exists(svmlpath + "/README.md"):
diff --git a/meta/recipes-devtools/python/python3-numpy_1.22.1.bb b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
index b79ce61fbf..ba0a777551 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.22.1.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
@@ -11,9 +11,8 @@ SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${S
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
file://0001-numpy-core-Define-RISCV-32-support.patch \
file://run-ptest \
- file://0001-numpy-core-setup.py-disable-svml-for-now.patch \
"
-SRC_URI[sha256sum] = "dd1968402ae20dfd59b34acd799b494be340c774f6295e9bf1c2b9842a5e416d"
+SRC_URI[sha256sum] = "093d513a460fd94f94c16193c3ef29b2d69a33e482071e3d6d6e561a700587a6"
UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
@@ -26,6 +25,10 @@ S = "${WORKDIR}/numpy-${PV}"
CLEANBROKEN = "1"
+do_compile:prepend() {
+ export NPY_DISABLE_SVML=1
+}
+
FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
# install what is needed for numpy.test()