summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-11-10 13:26:26 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-11-10 13:26:26 +0000
commitb618bcfeb94af391a5a9559efe75974c9661855e (patch)
treec882e87944cfb79d08af60a1c96d3cff80888729 /meta
parent5751ea748f6207f78bca684ea961b9b4bd1a88c1 (diff)
downloadopenembedded-core-contrib-b618bcfeb94af391a5a9559efe75974c9661855e.tar.gz
gstreamer: Fix a problem with configure if check has already been built
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/gstreamer/gstreamer/check_fix.patch19
-rw-r--r--meta/packages/gstreamer/gstreamer_0.10.20.bb2
2 files changed, 21 insertions, 0 deletions
diff --git a/meta/packages/gstreamer/gstreamer/check_fix.patch b/meta/packages/gstreamer/gstreamer/check_fix.patch
new file mode 100644
index 0000000000..5cdf6a04ea
--- /dev/null
+++ b/meta/packages/gstreamer/gstreamer/check_fix.patch
@@ -0,0 +1,19 @@
+Index: gstreamer-0.10.20/configure.ac
+===================================================================
+--- gstreamer-0.10.20.orig/configure.ac 2008-11-10 13:20:41.000000000 +0000
++++ gstreamer-0.10.20/configure.ac 2008-11-10 13:21:01.000000000 +0000
+@@ -501,13 +501,7 @@
+ AC_SUBST(GST_DISABLE_XML_DEFINE)
+
+ dnl check for "check", unit testing library/header
+-AM_PATH_CHECK(0.9.2,
+- [
+- HAVE_CHECK=yes
+- AC_MSG_NOTICE(CHECK_CFLAGS: $CHECK_CFLAGS)
+- AC_MSG_NOTICE(CHECK_LIBS: $CHECK_LIBS)
+- ],
+- HAVE_CHECK=no)
++HAVE_CHECK=no
+ AM_CONDITIONAL(HAVE_CHECK, test "x$HAVE_CHECK" = "xyes")
+
+ dnl pkg-config check that for libcheck that works for cross-compiling
diff --git a/meta/packages/gstreamer/gstreamer_0.10.20.bb b/meta/packages/gstreamer/gstreamer_0.10.20.bb
index 7b9d1ab3e0..32f6523b2a 100644
--- a/meta/packages/gstreamer/gstreamer_0.10.20.bb
+++ b/meta/packages/gstreamer/gstreamer_0.10.20.bb
@@ -5,11 +5,13 @@ PRIORITY = "optional"
LICENSE = "LGPL"
HOMEPAGE = "http://www.gstreamer.net/"
DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native"
+PR = "r1"
inherit autotools pkgconfig
SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
file://gst-inspect-check-error.patch;patch=1 \
+ file://check_fix.patch;patch=1 \
file://po-makefile-fix.patch;patch=1"
EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"