summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-06-25 15:26:54 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-06-25 15:26:54 +0000
commitbcfd6c036238b4e194460b6e48b9b4dc48de34ed (patch)
treecd9694a5ed9ab50a5ec423c19946af50dba8d62e /meta
parent1d73583a583288fb6c772b55320e304a893896bc (diff)
downloadopenembedded-core-contrib-bcfd6c036238b4e194460b6e48b9b4dc48de34ed.tar.gz
apt: unbreak host checking
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4729 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/apt/apt-0.7.14/nodoc.patch10
-rw-r--r--meta/packages/apt/apt-0.7.14/use-host.patch44
-rw-r--r--meta/packages/apt/apt.inc5
3 files changed, 54 insertions, 5 deletions
diff --git a/meta/packages/apt/apt-0.7.14/nodoc.patch b/meta/packages/apt/apt-0.7.14/nodoc.patch
index 9101847189..db8cf93717 100644
--- a/meta/packages/apt/apt-0.7.14/nodoc.patch
+++ b/meta/packages/apt/apt-0.7.14/nodoc.patch
@@ -2,9 +2,11 @@
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
---- apt-0.6.45exp2.orig/Makefile
-+++ apt-0.6.45exp2/Makefile
-@@ -17,7 +17,7 @@ all headers library clean veryclean bina
+--- apt-0.7.14.orig/Makefile
++++ apt-0.7.14/Makefile
+@@ -15,11 +15,11 @@ all headers library clean veryclean bina
+ $(MAKE) -C apt-inst $@
+ $(MAKE) -C methods $@
$(MAKE) -C cmdline $@
$(MAKE) -C ftparchive $@
$(MAKE) -C dselect $@
@@ -13,3 +15,5 @@
$(MAKE) -C po $@
# Some very common aliases
+ .PHONY: maintainer-clean dist-clean distclean pristine sanity
+ maintainer-clean dist-clean distclean pristine sanity: veryclean
diff --git a/meta/packages/apt/apt-0.7.14/use-host.patch b/meta/packages/apt/apt-0.7.14/use-host.patch
new file mode 100644
index 0000000000..894a697661
--- /dev/null
+++ b/meta/packages/apt/apt-0.7.14/use-host.patch
@@ -0,0 +1,44 @@
+---
+ buildlib/sizetable | 4 +++-
+ configure.in | 2 +-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+--- apt-0.7.14.orig/buildlib/sizetable
++++ apt-0.7.14/buildlib/sizetable
+@@ -9,16 +9,19 @@
+ #
+ # This is used primarily for the MD5 algorithm.
+ # The format is:-
+ # CPU endian sizeof: char, int, short, long
+ i386 little 1 4 2 4
++i486 little 1 4 2 4
++i586 little 1 4 2 4
++i686 little 1 4 2 4
+ armeb big 1 4 2 4
+ arm little 1 4 2 4
+ alpha little 1 4 2 8
+ mipsel little 1 4 2 4
+ sparc big 1 4 2 4
+ sparc64 big 1 4 2 8
+ m68k big 1 4 2 4
+ powerpc big 1 4 2 4
+ mips big 1 4 2 4
+ hppa big 1 4 2 4
+-m32r big 1 4 2 4
+\ No newline at end of file
++m32r big 1 4 2 4
+--- apt-0.7.14.orig/configure.in
++++ apt-0.7.14/configure.in
+@@ -86,11 +86,11 @@ AC_SUBST(BDBLIB)
+ dnl Converts the ARCH to be something singular for this general CPU family
+ dnl This is often the dpkg architecture string.
+ dnl First check against the full canonical canoncial-system-type in $target
+ dnl and if that fails, just look for the cpu
+ AC_MSG_CHECKING(debian architecture)
+-archset="`dpkg-architecture -qDEB_HOST_ARCH`"
++archset="`echo $host_alias|cut -d'-' -f1`"
+ if test "x$archset" = "x"; then
+ AC_MSG_ERROR([failed: use --host= or output from dpkg-architecture])
+ fi
+ AC_MSG_RESULT($archset)
+ AC_DEFINE_UNQUOTED(COMMON_ARCH,"$archset")
diff --git a/meta/packages/apt/apt.inc b/meta/packages/apt/apt.inc
index e42b63d22b..af08aa5d11 100644
--- a/meta/packages/apt/apt.inc
+++ b/meta/packages/apt/apt.inc
@@ -5,8 +5,9 @@ DEPENDS = "curl db"
RDEPENDS = "dpkg"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
- file://no-ko-translation.patch;patch=1 \
- "
+ file://no-ko-translation.patch;patch=1 \
+ file://use-host.patch;patch=1 \
+ "
S = "${WORKDIR}/apt-${PV}"