summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-21 00:58:17 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-21 00:58:17 +0000
commitfd37b166ecc3370c21260e172fbb9bbb4cdaea0d (patch)
treeabc1cadc4088e0e270072abcf37400ce585664b8 /meta
parent2e7d772b7e0e4941ea9ea9a4284fe1563a52aa03 (diff)
downloadopenembedded-core-contrib-fd37b166ecc3370c21260e172fbb9bbb4cdaea0d.tar.gz
linux-openmoko: Break immediate suspend on resume cycle
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3839 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/linux/linux-openmoko/break_suspend_cycle.patch34
-rw-r--r--meta/packages/linux/linux-openmoko_2.6.22.5.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/packages/linux/linux-openmoko/break_suspend_cycle.patch b/meta/packages/linux/linux-openmoko/break_suspend_cycle.patch
new file mode 100644
index 0000000000..2a721481d0
--- /dev/null
+++ b/meta/packages/linux/linux-openmoko/break_suspend_cycle.patch
@@ -0,0 +1,34 @@
+Index: linux-2.6.21/drivers/char/apm-emulation.c
+===================================================================
+--- linux-2.6.21.orig/drivers/char/apm-emulation.c 2008-02-21 00:32:41.000000000 +0000
++++ linux-2.6.21/drivers/char/apm-emulation.c 2008-02-21 00:33:43.000000000 +0000
+@@ -206,10 +206,18 @@
+ return ret;
+ }
+
++static in_suspend;
++
+ static void apm_suspend(void)
+ {
+ struct apm_user *as;
+- int err = pm_suspend(PM_SUSPEND_MEM);
++ int err;
++
++ in_suspend = 1;
++
++ err = pm_suspend(PM_SUSPEND_MEM);
++
++ in_suspend = 0;
+
+ /*
+ * Anyone on the APM queues will think we're still suspended.
+@@ -663,6 +671,9 @@
+ {
+ unsigned long flags;
+
++ if (in_suspend)
++ return;
++
+ spin_lock_irqsave(&kapmd_queue_lock, flags);
+ queue_add_event(&kapmd_queue, event);
+ spin_unlock_irqrestore(&kapmd_queue_lock, flags);
diff --git a/meta/packages/linux/linux-openmoko_2.6.22.5.bb b/meta/packages/linux/linux-openmoko_2.6.22.5.bb
index 65e8d459c1..a1de662c6a 100644
--- a/meta/packages/linux/linux-openmoko_2.6.22.5.bb
+++ b/meta/packages/linux/linux-openmoko_2.6.22.5.bb
@@ -9,7 +9,7 @@ KERNEL_RELEASE = "2.6.22.5"
#PV = "${VANILLA_VERSION}+${KERNEL_RELEASE}-moko11+svnr${SRCREV}"
PV = "${KERNEL_RELEASE}-moko11+svnr${SRCREV}"
-PR = "r14"
+PR = "r15"
KERNEL_IMAGETYPE = "uImage"
UBOOT_ENTRYPOINT = "30008000"
@@ -26,6 +26,7 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.ta
file://fix-gta01-flowcontrol2-2.6.22.5.patch;patch=1 \
file://gta-vibro-pwm-suspend.patch;patch=1 \
file://tweak_power_button.patch;patch=1 \
+ file://break_suspend_cycle.patch;patch=1 \
http://www.rpsys.net/openzaurus/patches/archive/input_power-r9.patch;patch=1 \
file://defconfig-${KERNEL_RELEASE}"