summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/usbutils/usbutils/iconv.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/usbutils/usbutils/iconv.patch')
-rw-r--r--meta/recipes-bsp/usbutils/usbutils/iconv.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-bsp/usbutils/usbutils/iconv.patch b/meta/recipes-bsp/usbutils/usbutils/iconv.patch
new file mode 100644
index 0000000000..c557334a75
--- /dev/null
+++ b/meta/recipes-bsp/usbutils/usbutils/iconv.patch
@@ -0,0 +1,40 @@
+This patch adds support for detecting iconv support using autotools
+uclibc does not have iconv implementation inside libc like glibc, therefore
+the existing checks were not sufficient, it worked for glibc but not for
+uclibc. The new patch portably detects the iconv support and adds the
+libiconv to linker cmdline
+
+This patch should be submitted upstream too
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: usbutils-007/configure.ac
+===================================================================
+--- usbutils-007.orig/configure.ac
++++ usbutils-007/configure.ac
+@@ -10,7 +10,9 @@ AC_USE_SYSTEM_EXTENSIONS
+ AC_SYS_LARGEFILE
+
+ AC_CHECK_HEADERS([byteswap.h])
+-AC_CHECK_FUNCS([nl_langinfo iconv])
++
++AM_GNU_GETTEXT
++AM_ICONV
+
+ AC_ARG_ENABLE(zlib,
+ AS_HELP_STRING(--disable-zlib,disable support for zlib))
+Index: usbutils-007/Makefile.am
+===================================================================
+--- usbutils-007.orig/Makefile.am
++++ usbutils-007/Makefile.am
+@@ -27,7 +27,7 @@ lsusb_CPPFLAGS = \
+ -DDATADIR=\"$(datadir)\"
+
+ lsusb_LDADD = \
+- $(LIBUSB_LIBS)
++ $(LIBUSB_LIBS) $(LIBICONV)
+
+ if HAVE_ZLIB
+ lsusb_CPPFLAGS += -DHAVE_LIBZ