summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/connman/connman-gnome_0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/connman/connman-gnome_0.5.bb')
-rw-r--r--meta/recipes-connectivity/connman/connman-gnome_0.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/connman/connman-gnome_0.5.bb b/meta/recipes-connectivity/connman/connman-gnome_0.5.bb
new file mode 100644
index 0000000000..6958ee57bb
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman-gnome_0.5.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "gtk frontend for connman"
+HOMEPAGE = "http://connman.net/"
+SECTION = "libs/network"
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://properties/main.c;beginline=1;endline=20;md5=50c77c81871308b033ab7a1504626afb \
+ file://common/connman-dbus.c;beginline=1;endline=20;md5=de6b485c0e717a0236402d220187717a"
+DEPENDS = "gtk+ dbus"
+PR = "r0"
+
+RRECOMMENDS_${PN} = "python python-dbus connman connman-plugin-ethernet connman-plugin-loopback connman-plugin-udhcp connman-plugin-wifi connman-plugin-fake connman-plugin-bluetooth connman-plugin-dnsproxy"
+
+SRC_URI = "http://www.kernel.org/pub/linux/network/connman/connman-gnome-${PV}.tar.gz \
+ file://connman-gnome.patch \
+ file://connman-applet.desktop"
+
+inherit autotools gtk-icon-cache
+
+do_install_append() {
+ install -d ${D}${datadir}/applications/
+ install ${WORKDIR}/connman-applet.desktop ${D}${datadir}/applications/
+}