summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.41.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ell/ell_0.41.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.41.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.41.bb b/meta/recipes-core/ell/ell_0.41.bb
new file mode 100644
index 0000000000..5fd3077bc3
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.41.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Embedded Linux Library"
+HOMEPAGE = "https://01.org/ell"
+DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
+low-level functionality for system daemons. It typically has no \
+dependencies other than the Linux kernel, C standard library, and \
+libdl (for dynamic linking). While ELL is designed to be efficient \
+and compact enough for use on embedded Linux platforms, it is not \
+limited to resource-constrained systems."
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
+
+DEPENDS = "dbus"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
+ file://0001-pem.c-do-not-use-rawmemchr.patch \
+ "
+SRC_URI[sha256sum] = "4e8dba6c53cf152dbd0fd1dc3d4c7b04abf79e20a948895f85943e586870505c"
+
+do_configure_prepend () {
+ mkdir -p ${S}/build-aux
+}