summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/help2man/help2man_1.48.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/help2man/help2man_1.48.1.bb')
-rw-r--r--meta/recipes-devtools/help2man/help2man_1.48.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man_1.48.1.bb b/meta/recipes-devtools/help2man/help2man_1.48.1.bb
new file mode 100644
index 0000000000..8341f2ba39
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man_1.48.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Program for creating simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
+SRC_URI[sha256sum] = "de8a74740bd058646567b92ab4ecdeb9da9f1a07cc7c4f607a3c14dd38d10799"
+
+inherit autotools
+
+# This is a hand-maintained aclocal.m4 but our autotools class currently deletes
+# aclocal.m4.
+EXTRA_AUTORECONF += "--exclude=aclocal"
+
+EXTRA_OECONF = "--disable-nls"
+
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}
+
+BBCLASSEXTEND = "native nativesdk"