summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mutter/mutter
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mutter/mutter')
-rw-r--r--meta/recipes-graphics/mutter/mutter/crosscompile.patch55
-rw-r--r--meta/recipes-graphics/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch10
-rw-r--r--meta/recipes-graphics/mutter/mutter/fix_pkgconfig.patch10
-rw-r--r--meta/recipes-graphics/mutter/mutter/nodocs.patch29
-rw-r--r--meta/recipes-graphics/mutter/mutter/nozenity.patch16
5 files changed, 120 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mutter/mutter/crosscompile.patch b/meta/recipes-graphics/mutter/mutter/crosscompile.patch
new file mode 100644
index 0000000000..b27383b09a
--- /dev/null
+++ b/meta/recipes-graphics/mutter/mutter/crosscompile.patch
@@ -0,0 +1,55 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2009-01-27 14:49:10.000000000 +0000
++++ git/configure.in 2009-01-27 15:29:41.000000000 +0000
+@@ -46,6 +46,32 @@
+ AC_LIBTOOL_WIN32_DLL
+ AM_PROG_LIBTOOL
+
++if test x"$CC_FOR_BUILD" = x; then
++ if test x"$cross_compiling" = xyes; then
++ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
++ else
++ CC_FOR_BUILD="$CC"
++ fi
++fi
++AC_SUBST([CC_FOR_BUILD])
++if test x"$CFLAGS_FOR_BUILD" = x; then
++ if test x"$cross_compiling" = xyes; then
++ AC_CHECK_PROGS(CFLAGS_FOR_BUILD, gcc cc)
++ else
++ CFLAGS_FOR_BUILD="$CFLAGS"
++ fi
++fi
++AC_SUBST([CFLAGS_FOR_BUILD])
++if test x"$LDFLAGS_FOR_BUILD" = x; then
++ if test x"$cross_compiling" = xyes; then
++ AC_CHECK_PROGS(LDFLAGS_FOR_BUILD, gcc cc)
++ else
++ LDFLAGS_FOR_BUILD="$LDFLAGS"
++ fi
++fi
++AC_SUBST([LDFLAGS_FOR_BUILD])
++
++
+ #### Integer sizes
+
+ AC_CHECK_SIZEOF(char)
+Index: git/src/Makefile.am
+===================================================================
+--- git.orig/src/Makefile.am 2009-01-27 15:25:31.000000000 +0000
++++ git/src/Makefile.am 2009-01-27 15:39:54.000000000 +0000
+@@ -168,11 +168,9 @@
+ metacity_dialog_SOURCES= \
+ ui/metacity-dialog.c
+
+-schema_bindings_SOURCES = \
+- core/schema-bindings.c \
+- metacity.schemas.in.in
++schema_bindings:
++ @CC_FOR_BUILD@ core/schema-bindings.c -I./include -I ../ @CFLAGS_FOR_BUILD@ @LDFLAGS_FOR_BUILD@ -o schema_bindings
+
+-schema_bindings_LDADD = @METACITY_LIBS@
+ metacity.schemas.in: schema_bindings ${srcdir}/metacity.schemas.in.in
+ @echo Generating keybinding schemas... ${srcdir}/metacity.schemas.in.in
+ ${builddir}/schema_bindings ${srcdir}/metacity.schemas.in.in ${builddir}/metacity.schemas.in
diff --git a/meta/recipes-graphics/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch b/meta/recipes-graphics/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch
new file mode 100644
index 0000000000..3714383bc1
--- /dev/null
+++ b/meta/recipes-graphics/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch
@@ -0,0 +1,10 @@
+Index: git/src/metacity-plugins.pc.in
+===================================================================
+--- git.orig/src/metacity-plugins.pc.in 2008-12-17 22:42:19.000000000 +0000
++++ git/src/metacity-plugins.pc.in 2008-12-17 22:42:25.000000000 +0000
+@@ -14,4 +14,4 @@
+ Requires: @CLUTTER_PACKAGE@
+ Version: @VERSION@
+ Libs: @CLUTTER_LIBS@
+-Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
++Cflags: -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
diff --git a/meta/recipes-graphics/mutter/mutter/fix_pkgconfig.patch b/meta/recipes-graphics/mutter/mutter/fix_pkgconfig.patch
new file mode 100644
index 0000000000..5ac5ecc609
--- /dev/null
+++ b/meta/recipes-graphics/mutter/mutter/fix_pkgconfig.patch
@@ -0,0 +1,10 @@
+Index: git/src/mutter-plugins.pc.in
+===================================================================
+--- git.orig/src/mutter-plugins.pc.in 2009-07-03 17:30:39.000000000 +0100
++++ git/src/mutter-plugins.pc.in 2009-07-03 18:03:09.000000000 +0100
+@@ -14,4 +14,4 @@
+ Requires: @CLUTTER_PACKAGE@
+ Version: @VERSION@
+ Libs: @CLUTTER_LIBS@
+-Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/mutter/mutter-private -DMUTTER_MAJOR_VERSION=${mutter_major_version} -DMUTTER_MINOR_VERSION=${mutter_minor_version} -DMUTTER_MICRO_VERSION=${mutter_micro_version} -DMUTTER_PLUGIN_API_VERSION=${mutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${plugindir}\"
++Cflags: -DWITH_CLUTTER -I${includedir}/mutter/mutter-private -DMUTTER_MAJOR_VERSION=${mutter_major_version} -DMUTTER_MINOR_VERSION=${mutter_minor_version} -DMUTTER_MICRO_VERSION=${mutter_micro_version} -DMUTTER_PLUGIN_API_VERSION=${mutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${plugindir}\"
diff --git a/meta/recipes-graphics/mutter/mutter/nodocs.patch b/meta/recipes-graphics/mutter/mutter/nodocs.patch
new file mode 100644
index 0000000000..98f43be5e8
--- /dev/null
+++ b/meta/recipes-graphics/mutter/mutter/nodocs.patch
@@ -0,0 +1,29 @@
+Index: git/Makefile.am
+===================================================================
+--- git.orig/Makefile.am 2009-01-27 13:26:12.000000000 +0000
++++ git/Makefile.am 2009-01-27 14:07:13.000000000 +0000
+@@ -1,5 +1,5 @@
+
+-SUBDIRS=src po doc
++SUBDIRS=src po
+
+ EXTRA_DIST = HACKING MAINTAINERS rationales.txt \
+ intltool-extract.in intltool-merge.in intltool-update.in
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2009-01-27 13:26:12.000000000 +0000
++++ git/configure.in 2009-01-27 14:11:16.000000000 +0000
+@@ -538,12 +538,9 @@
+
+ # Warnings are there for a reason
+ if test "x$GCC" = "xyes"; then
+- CFLAGS="$CFLAGS -Wall -Werror -ansi"
++ CFLAGS="$CFLAGS -Wall -ansi"
+ fi
+
+-# Use gnome-doc-utils:
+-GNOME_DOC_INIT([0.8.0])
+-
+ AC_CONFIG_FILES([
+ Makefile
+ doc/Makefile
diff --git a/meta/recipes-graphics/mutter/mutter/nozenity.patch b/meta/recipes-graphics/mutter/mutter/nozenity.patch
new file mode 100644
index 0000000000..06f5909533
--- /dev/null
+++ b/meta/recipes-graphics/mutter/mutter/nozenity.patch
@@ -0,0 +1,16 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2009-06-16 13:12:17.000000000 +0100
++++ git/configure.in 2009-06-16 13:12:33.000000000 +0100
+@@ -575,11 +575,6 @@
+ GCONF_SCHEMAS_INSTALL_FALSE=
+ fi
+
+-AC_PATH_PROG(ZENITY, zenity, no)
+-if test x"$ZENITY" = xno; then
+- AC_MSG_ERROR([zenity not found in your path - needed for dialogs])
+-fi
+-
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug enable debugging],,
+ enable_debug=no)