summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2021-02-23 22:01:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-26 15:19:28 +0000
commit41704717860c96ba91e19853e77df1f8100ed2ea (patch)
tree9749c00c00d388c4139749f3d55639161aaccce8
parent57df134b1be56a688f41851e5ff014dd859c0bc3 (diff)
downloadopenembedded-core-41704717860c96ba91e19853e77df1f8100ed2ea.tar.gz
libgit2: pull in updates from meta-oe
d62613046 libgit2: update to 1.1.0 ce47a064d libgit2: upgrade 1.0.0 -> 1.0.1 7d137c5b2 libgit2: Enable pcre2 regexp backend 14894a4c4 libgit2: Update to v1.0.0 7b39ea059 libgit2: Upgrade to 0.28.4 da358cf1f libgit2: Don't pass parameters with their default values to cmake bcd89f7cd libgit2: Upgrade 0.27.9 -> 0.28.3 87c9da253 libgit2: Upgrade 0.27.8 -> 0.27.9 Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/libgit2/libgit2_0.27.8.bb25
-rw-r--r--meta/recipes-support/libgit2/libgit2_1.1.0.bb22
2 files changed, 22 insertions, 25 deletions
diff --git a/meta/recipes-support/libgit2/libgit2_0.27.8.bb b/meta/recipes-support/libgit2/libgit2_0.27.8.bb
deleted file mode 100644
index a43408908c..0000000000
--- a/meta/recipes-support/libgit2/libgit2_0.27.8.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "the Git linkable library"
-HOMEPAGE = "http://libgit2.github.com/"
-LICENSE = "GPL-2.0-with-GCC-exception & MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3f2cd5d3cccd71d62066ba619614592b"
-
-DEPENDS = "curl openssl zlib libssh2 libgcrypt"
-
-SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v0.27"
-#v0.27.8
-SRCREV = "2882803ca2b2cdedd069746422155a23fdd002b2"
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-EXTRA_OECMAKE = "\
- -DTHREADSAFE=ON \
- -DBUILD_CLAR=OFF \
- -DSHA1_TYPE="builtin" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DBUILD_EXAMPLES=OFF \
- -DLIB_INSTALL_DIR=${libdir} \
-"
-
-BBCLASSEXTEND = "native"
diff --git a/meta/recipes-support/libgit2/libgit2_1.1.0.bb b/meta/recipes-support/libgit2/libgit2_1.1.0.bb
new file mode 100644
index 0000000000..2bbf59ea74
--- /dev/null
+++ b/meta/recipes-support/libgit2/libgit2_1.1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "the Git linkable library"
+HOMEPAGE = "http://libgit2.github.com/"
+LICENSE = "GPL-2.0-with-GCC-exception & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5b002a195fb7ea2d8d583f07eaff3a8e"
+
+DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
+
+SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.1"
+SRCREV = "7f4fa178629d559c037a1f72f79f79af9c1ef8ce"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "\
+ -DBUILD_CLAR=OFF \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DLIB_INSTALL_DIR=${libdir} \
+ -DREGEX_BACKEND='pcre2' \
+"
+
+BBCLASSEXTEND = "native"