summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/kernel.bbclass
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2023-06-27 10:16:40 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-28 23:17:11 +0100
commit38dc75c0e5eb7427ffcf201113fb45e0d5dad453 (patch)
tree581e43ef35bb1212e48b97ac484ef80f0047611a /meta/classes-recipe/kernel.bbclass
parentac921989991c319ecad01bec37c4ccaa15a7b58f (diff)
downloadopenembedded-core-38dc75c0e5eb7427ffcf201113fb45e0d5dad453.tar.gz
kernel: config modules directories are handled by kernel-module-split
Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/kernel.bbclass')
-rw-r--r--meta/classes-recipe/kernel.bbclass2
1 files changed, 0 insertions, 2 deletions
diff --git a/meta/classes-recipe/kernel.bbclass b/meta/classes-recipe/kernel.bbclass
index e82b696d1a..855c784149 100644
--- a/meta/classes-recipe/kernel.bbclass
+++ b/meta/classes-recipe/kernel.bbclass
@@ -483,8 +483,6 @@ kernel_do_install() {
install -m 0644 .config ${D}/${KERNEL_IMAGEDEST}/config-${KERNEL_VERSION}
install -m 0644 vmlinux ${D}/${KERNEL_IMAGEDEST}/vmlinux-${KERNEL_VERSION}
[ -e Module.symvers ] && install -m 0644 Module.symvers ${D}/${KERNEL_IMAGEDEST}/Module.symvers-${KERNEL_VERSION}
- install -d ${D}${sysconfdir}/modules-load.d
- install -d ${D}${sysconfdir}/modprobe.d
}
# Must be ran no earlier than after do_kernel_checkout or else Makefile won't be in ${S}/Makefile