summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-04 12:18:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-24 11:38:16 +0100
commit0d6abd0ff634604cdde2b80f625d6ca2a015948a (patch)
tree94ebff5b49a312a1ecfea66d4ebad6f7960a10c3 /meta/recipes-connectivity
parent0bc79de634841c57868be3d7d8b0fd8bf47ccc18 (diff)
downloadopenembedded-core-0d6abd0ff634604cdde2b80f625d6ca2a015948a.tar.gz
connman: backport test script fixes
Those fixes are required to get the test scripts to work with current 0.79 DBus API. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/connman/connman/test-set-ipv4-method-api-fix.patch50
-rw-r--r--meta/recipes-connectivity/connman/connman/test-set-ipv6-method-api-fix.patch55
-rw-r--r--meta/recipes-connectivity/connman/connman_0.79.bb4
3 files changed, 108 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/connman/connman/test-set-ipv4-method-api-fix.patch b/meta/recipes-connectivity/connman/connman/test-set-ipv4-method-api-fix.patch
new file mode 100644
index 0000000000..78eb19a770
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman/test-set-ipv4-method-api-fix.patch
@@ -0,0 +1,50 @@
+From 0b817dd3096f5c3ca8f0b868ee55ea550054137b Mon Sep 17 00:00:00 2001
+From: Daniel Wagner <daniel.wagner@bmw-carit.de>
+Date: Mon, 19 Mar 2012 14:03:27 +0100
+Subject: [PATCH 3/3] set-ipv4-method: The arguments have to be wrapped into a
+ variant
+
+Fixes BMC#24986
+
+Upstream-Status: Backport
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ test/set-ipv4-method | 11 +++++++----
+ 1 file changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/test/set-ipv4-method b/test/set-ipv4-method
+index 820b24b..235113f 100755
+--- a/test/set-ipv4-method
++++ b/test/set-ipv4-method
+@@ -3,6 +3,9 @@
+ import sys
+ import dbus
+
++def make_variant(string):
++ return dbus.String(string, variant_level=1)
++
+ def print_usage():
+ print "Usage: %s <service> [off|dhcp|manual <address> [netmask] [gateway]]" % (sys.argv[0])
+
+@@ -20,13 +23,13 @@ properties = service.GetProperties()
+
+ print "Setting method %s for %s" % (sys.argv[2], sys.argv[1])
+
+-ipv4_configuration = { "Method": sys.argv[2] }
++ipv4_configuration = { "Method": make_variant(sys.argv[2]) }
+ if (len(sys.argv) > 3):
+- ipv4_configuration["Address"] = sys.argv[3]
++ ipv4_configuration["Address"] = make_variant(sys.argv[3])
+ if (len(sys.argv) > 4):
+- ipv4_configuration["Netmask"] = sys.argv[4]
++ ipv4_configuration["Netmask"] = make_variant(sys.argv[4])
+ if (len(sys.argv) > 5):
+- ipv4_configuration["Gateway"] = sys.argv[5]
++ ipv4_configuration["Gateway"] = make_variant(sys.argv[5])
+
+ service.SetProperty("IPv4.Configuration", ipv4_configuration)
+ print "New IPv4.Configuration: ", ipv4_configuration
+--
+1.7.9.5
+
diff --git a/meta/recipes-connectivity/connman/connman/test-set-ipv6-method-api-fix.patch b/meta/recipes-connectivity/connman/connman/test-set-ipv6-method-api-fix.patch
new file mode 100644
index 0000000000..773127bcec
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman/test-set-ipv6-method-api-fix.patch
@@ -0,0 +1,55 @@
+From 2885e71c9c0df7ea9866e91ab79d255eaa8de53d Mon Sep 17 00:00:00 2001
+From: Daniel Wagner <daniel.wagner@bmw-carit.de>
+Date: Mon, 19 Mar 2012 14:03:28 +0100
+Subject: [PATCH 2/3] set-ipv6-method: The arguments have to be wrapped into a
+ variant
+
+Fixes BMC#24986
+
+Upstream-Status: Backport
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ test/set-ipv6-method | 13 ++++++++-----
+ 1 file changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/test/set-ipv6-method b/test/set-ipv6-method
+index 7f60b88..4f2de09 100755
+--- a/test/set-ipv6-method
++++ b/test/set-ipv6-method
+@@ -3,6 +3,9 @@
+ import sys
+ import dbus
+
++def make_variant(string):
++ return dbus.String(string, variant_level=1)
++
+ def print_usage():
+ print "Usage: %s <service> off|manual|auto [<address> [prefixlen] [gateway]] [<privacy>]" % (sys.argv[0])
+
+@@ -19,17 +22,17 @@ properties = service.GetProperties()
+
+ print "Setting method %s for %s" % (sys.argv[2], sys.argv[1])
+
+-ipv6_configuration = { "Method": sys.argv[2] }
++ipv6_configuration = { "Method": make_variant(sys.argv[2])}
+ if sys.argv[2] == "auto":
+ if (len(sys.argv) > 3):
+- ipv6_configuration["Privacy"] = sys.argv[3]
++ ipv6_configuration["Privacy"] = make_variant(sys.argv[3])
+ else:
+ if (len(sys.argv) > 3):
+- ipv6_configuration["Address"] = sys.argv[3]
++ ipv6_configuration["Address"] = make_variant(sys.argv[3])
+ if (len(sys.argv) > 4):
+- ipv6_configuration["PrefixLength"] = sys.argv[4]
++ ipv6_configuration["PrefixLength"] = make_variant(sys.argv[4])
+ if (len(sys.argv) > 5):
+- ipv6_configuration["Gateway"] = sys.argv[5]
++ ipv6_configuration["Gateway"] = make_variant(sys.argv[5])
+
+ service.SetProperty("IPv6.Configuration", ipv6_configuration)
+ print "New IPv6.Configuration: ", ipv6_configuration
+--
+1.7.9.5
+
diff --git a/meta/recipes-connectivity/connman/connman_0.79.bb b/meta/recipes-connectivity/connman/connman_0.79.bb
index da48e94932..4c57dab80d 100644
--- a/meta/recipes-connectivity/connman/connman_0.79.bb
+++ b/meta/recipes-connectivity/connman/connman_0.79.bb
@@ -7,6 +7,8 @@ SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git \
file://ethernet_default.patch \
file://disable_alg-test.patch \
file://0001-plugin.h-Change-visibility-to-default-for-debug-symb.patch \
+ file://test-set-ipv4-method-api-fix.patch \
+ file://test-set-ipv6-method-api-fix.patch \
file://connman"
S = "${WORKDIR}/git"
-PR = "r2"
+PR = "r3"