summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-11 21:01:51 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-14 07:17:26 +0000
commit4a28057849f9edc6ac06d115531f579673d788b5 (patch)
tree8baca135938b1e8ff43094d5637d195b587d573c /meta/recipes-core/images
parentf3f63ff01971df7d67213a7e7b1294489a5d3c0f (diff)
downloadopenembedded-core-4a28057849f9edc6ac06d115531f579673d788b5.tar.gz
ptest-packagelists: Simplify ptest list/code
All the usage sites remove the -ptest suffix. Simply the original list instead and clean up the code. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images')
-rw-r--r--meta/recipes-core/images/core-image-ptest-all.bb4
-rw-r--r--meta/recipes-core/images/core-image-ptest.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/images/core-image-ptest-all.bb b/meta/recipes-core/images/core-image-ptest-all.bb
index 81c9b2d68a..c84e653d6e 100644
--- a/meta/recipes-core/images/core-image-ptest-all.bb
+++ b/meta/recipes-core/images/core-image-ptest-all.bb
@@ -12,9 +12,9 @@ require conf/distro/include/ptest-packagelists.inc
PTESTS = "${PTESTS_FAST} ${PTESTS_SLOW}"
do_testimage[noexec] = "1"
-do_testimage[depends] = "${@' '.join(['core-image-ptest-'+x.replace('-ptest', '')+':do_testimage' for x in d.getVar('PTESTS').split()])}"
+do_testimage[depends] = "${@' '.join(['core-image-ptest-'+x+':do_testimage' for x in d.getVar('PTESTS').split()])}"
-do_build[depends] = "${@' '.join(['core-image-ptest-'+x.replace('-ptest', '')+':do_build' for x in d.getVar('PTESTS').split()])}"
+do_build[depends] = "${@' '.join(['core-image-ptest-'+x+':do_build' for x in d.getVar('PTESTS').split()])}"
# normally image.bbclass would do this
EXCLUDE_FROM_WORLD = "1"
diff --git a/meta/recipes-core/images/core-image-ptest.bb b/meta/recipes-core/images/core-image-ptest.bb
index 0c67943b05..90c26641ba 100644
--- a/meta/recipes-core/images/core-image-ptest.bb
+++ b/meta/recipes-core/images/core-image-ptest.bb
@@ -11,7 +11,7 @@ PTESTS = "${PTESTS_SLOW} ${PTESTS_FAST}"
IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"
-BBCLASSEXTEND = "${@' '.join(['mcextend:'+x.replace('-ptest', '') for x in d.getVar('PTESTS').split()])}"
+BBCLASSEXTEND = "${@' '.join(['mcextend:'+x for x in d.getVar('PTESTS').split()])}"
# The image can sufficiently large (~1.8GB) that we need to be careful that it fits in a live
# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the