summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-12 11:41:41 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-13 09:41:39 +0100
commit1bc5378db760963e2ad46542f2907dd6a592eb66 (patch)
tree852a433a6a76f588691da46fbe63aa2c5b3aef80 /meta/recipes-core
parent958133f4e97275d1f2c74a7e715c4506cca3582f (diff)
downloadopenembedded-core-1bc5378db760963e2ad46542f2907dd6a592eb66.tar.gz
libxml2: Use python3targetconfig to fix reproducibility issue
We're seeing pthread being linked sometimes and not others leading to non-reproducible target binaries. The reason is mixing the native python config with the target one. We should use the target one. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.12.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.12.bb b/meta/recipes-core/libxml/libxml2_2.9.12.bb
index 3105889c16..c387587dfd 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.12.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.12.bb
@@ -36,7 +36,7 @@ PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
inherit autotools pkgconfig binconfig-disabled ptest
-inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
RDEPENDS:${PN}-ptest += "bash make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"