summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.19.3.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2014-02-06 17:29:32 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-08 21:03:27 +0000
commitb5b4898cd409036161c62891e9618d9ab3f891f9 (patch)
tree9ef27df66a47889db28b9cd492cf64bf02bb1c27 /meta/recipes-devtools/python/python-pycurl_7.19.3.bb
parentb18fb872baa0deb89f1b8250883122fb5f6328c5 (diff)
downloadopenembedded-core-b5b4898cd409036161c62891e9618d9ab3f891f9.tar.gz
python-pycurl: upgrade to 7.19.3
Changes: * Refreshed no-static-link.patch; * LGPL&MIT license files changed names; * MIT license file added a contributor to the list; * README.rst license snippet changed to reflect the filename changes and the new contributor; Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.3.bb b/meta/recipes-devtools/python/python-pycurl_7.19.3.bb
new file mode 100644
index 0000000000..aee6cdda82
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.3.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Python bindings for libcurl"
+HOMEPAGE = "http://pycurl.sourceforge.net/"
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1+ | MIT"
+LIC_FILES_CHKSUM = "file://README.rst;beginline=204;endline=219;md5=57e5ab0c0f964533fc59d93dec5695bb \
+ file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
+ file://COPYING-MIT;md5=e8200955c773b2a0fd6cea36ea5e87be"
+
+DEPENDS = "curl python"
+RDEPENDS_${PN} = "python-core curl"
+SRCNAME = "pycurl"
+
+SRC_URI = "\
+ http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
+ file://no-static-link.patch \
+"
+
+SRC_URI[archive.md5sum] = "b9091b7438d3de1552e28862d2971cd1"
+SRC_URI[archive.sha256sum] = "05e48835fe445ff327dcd373f49d9970e0b828a07cd4d08a23264507a742d616"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# need to export these variables for python-config to work
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+BBCLASSEXTEND = "native"
+
+do_install_append() {
+ rm -rf ${D}${datadir}/share
+}