summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-testtools.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-19 16:07:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-20 11:38:15 +0000
commitb566b1e32c7993d1ab7795562f648e52ce186a70 (patch)
tree921f025e8db894d8edc26560c66783fa7c71eaa1 /meta/recipes-devtools/python/python-testtools.inc
parentf5e6183b9557477bef74024a587de0bfcc2b7c0d (diff)
downloadopenembedded-core-b566b1e32c7993d1ab7795562f648e52ce186a70.tar.gz
python: Drop ${PYTHON_PN}
python 2 is gone and we don't need the abstraction now, drop the remaining usage of this variable. The definition in python3-dir.bbclass is left for now for other layers. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-testtools.inc')
-rw-r--r--meta/recipes-devtools/python/python-testtools.inc12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python-testtools.inc b/meta/recipes-devtools/python/python-testtools.inc
index 759166d63d..e9dd97ec1c 100644
--- a/meta/recipes-devtools/python/python-testtools.inc
+++ b/meta/recipes-devtools/python/python-testtools.inc
@@ -9,19 +9,19 @@ inherit pypi
SRC_URI[sha256sum] = "df6de96010e29ee21f637a147eabf30d50b25e3841dd1d68f93ee89ce77e366c"
DEPENDS += " \
- ${PYTHON_PN}-pbr \
+ python3-pbr \
"
# Satisfy setup.py 'setup_requires'
DEPENDS += " \
- ${PYTHON_PN}-pbr-native \
+ python3-pbr-native \
"
RDEPENDS:${PN} += "\
- ${PYTHON_PN}-doctest \
- ${PYTHON_PN}-extras \
- ${PYTHON_PN}-pbr \
- ${PYTHON_PN}-six \
+ python3-doctest \
+ python3-extras \
+ python3-pbr \
+ python3-six \
"
BBCLASSEXTEND = "nativesdk"