summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cython_0.29.23.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-30 14:25:58 +0100
commit42344347be29f0997cc2f7636d9603b1fe1875ae (patch)
tree9a061dbb101c5baf3f4e8c8be1322a1794584f3c /meta/recipes-devtools/python/python3-cython_0.29.23.bb
parent72c04cb3ca78208a135275d6dd43ad500b663cb5 (diff)
downloadopenembedded-core-42344347be29f0997cc2f7636d9603b1fe1875ae.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cython_0.29.23.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cython_0.29.23.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3-cython_0.29.23.bb b/meta/recipes-devtools/python/python3-cython_0.29.23.bb
index 2ec4033fa0..296fb39b6f 100644
--- a/meta/recipes-devtools/python/python3-cython_0.29.23.bb
+++ b/meta/recipes-devtools/python/python3-cython_0.29.23.bb
@@ -1,7 +1,7 @@
inherit setuptools3
require python-cython.inc
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
python3-setuptools \
"
@@ -10,7 +10,7 @@ RDEPENDS_${PN} += "\
# architecture.
DISTUTILS_INSTALL_ARGS += "--skip-build"
-do_install_append() {
+do_install:append() {
# rename scripts that would conflict with the Python 2 build of Cython
mv ${D}${bindir}/cython ${D}${bindir}/cython3
mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3