summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2021-07-09 16:29:41 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-13 14:24:47 +0100
commit78e9e7c48e673cab8580f00efb08f5d8783b5927 (patch)
tree64f8259ab2f9ab5b495ea92be8e7a4bc3637ca62 /meta/recipes-devtools/tcltk
parentfb1027896a263cd91e2378a4e97dbdf0807b306b (diff)
downloadopenembedded-core-78e9e7c48e673cab8580f00efb08f5d8783b5927.tar.gz
tcl: suffix all Tcl man pages instead of using alternatives
Both Perl and Tcl want to install Thread.3. Alternatives is a terrible idea for manpages that don't correspond to binaries, instead just tell Tcl to suffix the manpages so this is Thread.3tcl. Signed-off-by: Ross Burton <ross.burton@arm.com>
Diffstat (limited to 'meta/recipes-devtools/tcltk')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.11.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.11.bb b/meta/recipes-devtools/tcltk/tcl_8.6.11.bb
index efb36b32dd..f5bb6b1a18 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.11.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.11.bb
@@ -34,9 +34,9 @@ S = "${WORKDIR}/${BPN}${PV}/unix"
PSEUDO_IGNORE_PATHS .= ",${WORKDIR}/${BPN}${PV}"
VER = "${PV}"
-inherit autotools ptest binconfig update-alternatives
+inherit autotools ptest binconfig
-EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}"
+EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir} --enable-man-suffix"
do_compile_prepend() {
echo > ${S}/../compat/fixstrtod.c
@@ -65,9 +65,6 @@ FILES_tcl-lib = "${libdir}/libtcl8.6.so.*"
FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8.6 ${libdir}/tcl8"
FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh"
-ALTERNATIVE_${PN}-doc = "Thread.3"
-ALTERNATIVE_LINK_NAME[Thread.3] = "${mandir}/man3/Thread.3"
-
# isn't getting picked up by shlibs code
RDEPENDS_${PN} += "tcl-lib"
RDEPENDS_${PN}-ptest += "libgcc"