summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-12 12:51:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-13 09:41:39 +0100
commit1189f95e05c80286e009e1ab46a603ee5b7ca239 (patch)
tree0748dd0257094d8e8b7abd2476634eee778f5a02 /meta/recipes-devtools
parent3fe5101b335384ef83e96ccc58687fd631164075 (diff)
downloadopenembedded-core-1189f95e05c80286e009e1ab46a603ee5b7ca239.tar.gz
bootchart2: Don't compile python modules
"make install" may attempt to compile the python modules but it uses the host python and host paths which means the binaries are not reproducbile. Make things consistent. If anyone needs compiling, it will beed to be fixed to be cross compile compatible. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
index 974faa3b3f..c24613b74e 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
@@ -99,6 +99,10 @@ SRC_URI = "git://github.com/xrmx/bootchart.git \
S = "${WORKDIR}/git"
SRCREV = "868a2afab9da34f32c007d773b77253c93104636"
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
+
inherit systemd update-rc.d python3native update-alternatives
ALTERNATIVE:${PN} = "bootchartd"
@@ -131,7 +135,7 @@ do_install () {
export PKGLIBDIR="${base_libdir}/bootchart"
export SYSTEMD_UNIT_DIR="${systemd_system_unitdir}"
- oe_runmake install
+ oe_runmake install NO_PYTHON_COMPILE=1
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/bootchartd_stop.sh ${D}${sysconfdir}/init.d