summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2021-05-20 10:58:20 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-25 10:04:06 +0100
commit286e60702aa1d8448efc703fa40735e079e6a027 (patch)
tree33b89490c158b1e1a28aacf367de5d5fde19997f /meta/recipes-devtools
parent36814f5467c9abd84aeb05916b4fd49f766f4f9f (diff)
downloadopenembedded-core-286e60702aa1d8448efc703fa40735e079e6a027.tar.gz
bison: Make libtextstyle and libreadline optional
Bison opportunistically enables libtextstyle and libreadline support if they're installed on the build host. Since textstyle and readline aren't part of uninative avoid host contamination by making their support configurable and disabled by default in the native case. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/bison/bison_3.7.6.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.7.6.bb b/meta/recipes-devtools/bison/bison_3.7.6.bb
index a7f01c3299..a8d57f2742 100644
--- a/meta/recipes-devtools/bison/bison_3.7.6.bb
+++ b/meta/recipes-devtools/bison/bison_3.7.6.bb
@@ -15,10 +15,25 @@ SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
"
SRC_URI[sha256sum] = "67d68ce1e22192050525643fc0a7a22297576682bef6a5c51446903f5aeef3cf"
+inherit autotools gettext texinfo
+
# No point in hardcoding path to m4, just use PATH
-EXTRA_OECONF += "M4=m4"
+CACHED_CONFIGUREVARS = "ac_cv_path_M4=m4"
-inherit autotools gettext texinfo
+PACKAGECONFIG ??= "readline ${@ 'textstyle' if d.getVar('USE_NLS') == 'yes' else ''}"
+PACKAGECONFIG_class-native ??= ""
+
+# Make readline and textstyle optional. There are recipie for these, but leave them
+# disabled for the native recipe. This prevents host contamination of the native tool.
+PACKAGECONFIG[readline] = "--with-libreadline-prefix,--without-libreadline-prefix,readline"
+PACKAGECONFIG[textstyle] = "--with-libtextstyle-prefix,--without-libtextstyle-prefix,gettext"
+
+# Include the cached configure variables, configure is really good at finding
+# libreadline, even if we don't want it.
+CACHED_CONFIGUREVARS += "${@bb.utils.contains('PACKAGECONFIG', 'readline', '', ' \
+ ac_cv_header_readline_history_h=no \
+ ac_cv_header_readline_readline_h=no \
+ gl_cv_lib_readline=no', d)}"
# The automatic m4 path detection gets confused, so force the right value
acpaths = "-I ./m4"