summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorJingdong Lu <jingdong.lu@windriver.com>2010-11-24 12:37:58 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-10 23:13:00 +0000
commitd905d18fe71af0620950c5213ec7822048831177 (patch)
treeefc2a0ee1b07ed485f740bd1fafc59dc63e3e6b9 /meta/recipes-devtools
parent0d5e71e741b6f2b7564ca77a99293a4a0954b092 (diff)
downloadopenembedded-core-d905d18fe71af0620950c5213ec7822048831177.tar.gz
libxml-perl: Add libxml-perl
Add libxml-perl in order to enable graphic LSB test(OLVER-Core test). [sgw@linux.intel.com: fixed LICENSE] Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/libxml-perl_0.08.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-perl_0.08.bb b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
new file mode 100644
index 0000000000..04a78e34d0
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "libxml-perl is a collection of smaller Perl modules, scripts, and \
+documents for working with XML in Perl. libxml-perl software \
+works in combination with XML::Parser, PerlSAX, XML::DOM, \
+XML::Grove and others."
+SUMMARY = "Collection of Perl modules for working with XML."
+SECTION = "libs"
+LICENSE = "Artistic | GPLv1+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
+
+DEPENDS += "libxml-parser-perl"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/XML/${PN}-${PV}.tar.gz"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+