summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/files
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-03-14 16:39:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-19 13:36:53 +0000
commit768eb8e8590e3b9cc033d8544a01ae34d3ed16b1 (patch)
treea79cf8f811dbf6a267d9a02a748721378cd8cfa8 /meta/recipes-extended/at/files
parent4bdd31625ba9d4f9f0e9dc7775ad650d53dd221a (diff)
downloadopenembedded-core-768eb8e8590e3b9cc033d8544a01ae34d3ed16b1.tar.gz
at: upgrade to 3.1.13
Moved patches into a common directory. Added SOB to use-ldflags.patch. Removed nonstripbinaries patch which was included in this release. Minor formatting cleanups. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-extended/at/files')
-rw-r--r--meta/recipes-extended/at/files/configure-add-enable-pam.patch25
-rw-r--r--meta/recipes-extended/at/files/configure.patch29
-rw-r--r--meta/recipes-extended/at/files/fix_parallel_build_error.patch28
-rw-r--r--meta/recipes-extended/at/files/nonstripbinaries.patch26
-rw-r--r--meta/recipes-extended/at/files/pam.conf.patch21
-rw-r--r--meta/recipes-extended/at/files/use-ldflags.patch5
6 files changed, 106 insertions, 28 deletions
diff --git a/meta/recipes-extended/at/files/configure-add-enable-pam.patch b/meta/recipes-extended/at/files/configure-add-enable-pam.patch
new file mode 100644
index 0000000000..1e5efef128
--- /dev/null
+++ b/meta/recipes-extended/at/files/configure-add-enable-pam.patch
@@ -0,0 +1,25 @@
+Upstream-Status: Pending
+
+--- at-3.1.12/configure.ac 2011-06-23 14:51:03.653572945 +0800
++++ at-3.1.12/configure.ac.new 2011-06-27 16:12:14.903572945 +0800
+@@ -81,10 +81,18 @@
+ AC_FUNC_VPRINTF
+ AC_FUNC_GETLOADAVG
+ AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
++
++AC_ARG_WITH([pam],
++ [AS_HELP_STRING([--without-pam], [without PAM support])])
++
++if test "x$with_pam" != xno; then
+ AC_CHECK_HEADERS(security/pam_appl.h, [
+ PAMLIB="-lpam"
+- AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
+-])
++ AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])],
++ [if test "x$with_pam" = xyes; then
++ AC_MSG_ERROR([PAM selected but security/pam_misc.h not found])
++ fi])
++fi
+
+ dnl Checking for programs
+
diff --git a/meta/recipes-extended/at/files/configure.patch b/meta/recipes-extended/at/files/configure.patch
new file mode 100644
index 0000000000..14310e3354
--- /dev/null
+++ b/meta/recipes-extended/at/files/configure.patch
@@ -0,0 +1,29 @@
+
+Fix cross-compilation issues in configure.ac
+Derived from an OE patch for at-3.1.8
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+Index: at-3.1.12/configure.ac
+===================================================================
+--- at-3.1.12.orig/configure.ac
++++ at-3.1.12/configure.ac
+@@ -38,12 +38,11 @@ case "$host" in
+ AC_MSG_RESULT(no)
+ ;;
+ esac
++if [ X"${cross_compiling}" = Xno ]; then
+ AC_MSG_CHECKING(Trying to compile a trivial ANSI C program)
+-AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.),
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.))
++AC_RUN_IFELSE([AC_LANG_SOURCE([[ main(int ac, char **av) { return 0; } ]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
++ AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)],[AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)])
++fi
+
+ AC_MSG_CHECKING(__attribute__((noreturn)))
+ AC_TRY_COMPILE([], [void __attribute__((noreturn)) panic(void);],
diff --git a/meta/recipes-extended/at/files/fix_parallel_build_error.patch b/meta/recipes-extended/at/files/fix_parallel_build_error.patch
new file mode 100644
index 0000000000..877be35aaf
--- /dev/null
+++ b/meta/recipes-extended/at/files/fix_parallel_build_error.patch
@@ -0,0 +1,28 @@
+make -j was failing sometimesa like this
+| ccache i586-poky-linux-gcc -march=i586 --sysroot=/home/nitin/build/build0/tmp/sysroots/i586-poky-linux -I. -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types -o atd atd.o daemon.o -lfl -lpam -Wl,-O1 -Wl,--as-needed
+| parsetime.l:5:19: fatal error: y.tab.h: No such file or directory
+| compilation terminated.
+| make: *** [lex.yy.o] Error 1
+| make: *** Waiting for unfinished jobs....
+
+Fixed the issue by adding a dependancy in the makefile.
+Nitin <nitin.a.kamble@intel.com>
+2010/09/02
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+Index: at-3.1.12/Makefile.in
+===================================================================
+--- at-3.1.12.orig/Makefile.in
++++ at-3.1.12/Makefile.in
+@@ -83,6 +83,8 @@ y.tab.c y.tab.h: parsetime.y
+ lex.yy.c: parsetime.l
+ $(LEX) -i parsetime.l
+
++parsetime.l: y.tab.h
++
+ atrun: atrun.in
+ configure
+
diff --git a/meta/recipes-extended/at/files/nonstripbinaries.patch b/meta/recipes-extended/at/files/nonstripbinaries.patch
deleted file mode 100644
index 2b251db131..0000000000
--- a/meta/recipes-extended/at/files/nonstripbinaries.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Upstream-Status: Pending
-#Because remove nonrootinstall patch, the stripping of the binaries can not
-#be handled.
-#This patch is to handle the stripping of the binaries.
-#Mei Lei<lei.mei@intel.com> make this change
-diff --git at-3.1.12.orig/Makefile.in at-3.1.12/Makefile.in
-index dae6b7d..71a5d89 100644
---- at-3.1.12.orig/Makefile.in
-+++ at-3.1.12/Makefile.in
-@@ -97,14 +97,14 @@ install: all
- chmod 600 $(IROOT)$(LFILE)
- chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
- test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(IROOT)$(etcdir)/
-- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 -s at $(IROOT)$(bindir)
-+ $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(IROOT)$(bindir)
- $(LN_S) -f at $(IROOT)$(bindir)/atq
- $(LN_S) -f at $(IROOT)$(bindir)/atrm
- $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
-- $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
-+ $(INSTALL) -g root -o root -m 755 atd $(IROOT)$(sbindir)
- $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
- $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
- cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
diff --git a/meta/recipes-extended/at/files/pam.conf.patch b/meta/recipes-extended/at/files/pam.conf.patch
new file mode 100644
index 0000000000..dfe76d7487
--- /dev/null
+++ b/meta/recipes-extended/at/files/pam.conf.patch
@@ -0,0 +1,21 @@
+oe doesn't support "@include", use the concrete directive instead.
+
+Upstream-Status: Pending
+
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+--- at-3.1.12/pam.conf.orig 2009-11-23 23:11:52.000000000 +0800
++++ at-3.1.12/pam.conf 2011-07-15 11:14:04.132818950 +0800
+@@ -2,8 +2,8 @@
+ # The PAM configuration file for the at daemon
+ #
+
+-auth required pam_env.so
+-@include common-auth
+-@include common-account
+-@include common-session-noninteractive
+-session required pam_limits.so
++auth required pam_env.so
++auth include common-auth
++account include common-account
++session include common-session-noninteractive
++session required pam_limits.so
diff --git a/meta/recipes-extended/at/files/use-ldflags.patch b/meta/recipes-extended/at/files/use-ldflags.patch
index fdd1908efc..4c698003d0 100644
--- a/meta/recipes-extended/at/files/use-ldflags.patch
+++ b/meta/recipes-extended/at/files/use-ldflags.patch
@@ -1,8 +1,9 @@
Upstream-Status: Pending
-# Ensure use of $LDFLAGS during build
-# Derived from an OE patch for at-3.1.8
+Ensure use of $LDFLAGS during build
+Derived from an OE patch for at-3.1.8
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
--- at-3.1.12.orig/Makefile.in 2009-11-23 07:11:52.000000000 -0800
+++ at-3.1.12/Makefile.in 2010-07-20 16:28:04.000000000 -0700
@@ -65,13 +65,13 @@