summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cpio
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-07-02 01:56:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-07-10 11:36:06 +0100
commitc74697e194fe07cb4a2fee45142ae626996fd294 (patch)
treeb25ef518878f809073c5156f4cf12de2a8ed1bd9 /meta/recipes-extended/cpio
parenta74206f32e84a38ac53a9dddb33f8e97714e5aca (diff)
downloadopenembedded-core-c74697e194fe07cb4a2fee45142ae626996fd294.tar.gz
cpio: respect MLPREFIX for PACKAGE_WRITE_DEPS
* unlike DEPENDS/RDEPENDS the PACKAGE_WRITE_DEPS dependency isn't automatically extended with MLPREFIX, causing lib32-cpio to depend on 64bit ptest-runner (and all its deps) * append it only for class-target to avoid nativesdk-cpio depending on target ptest-runner (before this patch) and depending on non-existent nativesdk-ptest-runner with this patch (as nativesdk.bbclass sets MLPREFIX to "nativesdk-") stdio: WARNING: Nothing PROVIDES 'nativesdk-ptest-runner'. Close matches: stdio: WARNING: Nothing RPROVIDES 'nativesdk-cpio' (but virtual:nativesdk:/home/pokybuild/yocto-worker/a-full/build/meta/recipes-extended/cpio/cpio_2.14.bb RDEPENDS on or otherwise requires it) stdio: WARNING: Nothing RPROVIDES 'nativesdk-cpio-dev' (but virtual:nativesdk:/home/pokybuild/yocto-worker/a-full/build/meta/recipes-extended/cpio/cpio_2.14.bb RDEPENDS on or otherwise requires it) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/cpio')
-rw-r--r--meta/recipes-extended/cpio/cpio_2.14.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/cpio/cpio_2.14.bb b/meta/recipes-extended/cpio/cpio_2.14.bb
index e55fb70cb1..45eb9de8e0 100644
--- a/meta/recipes-extended/cpio/cpio_2.14.bb
+++ b/meta/recipes-extended/cpio/cpio_2.14.bb
@@ -66,7 +66,7 @@ do_install_ptest_base:append() {
# The tests need to run as a non-root user, so pull in the ptest user
DEPENDS:append:class-target = "${@bb.utils.contains('PTEST_ENABLED', '1', ' ptest-runner', '', d)}"
-PACKAGE_WRITE_DEPS += "ptest-runner"
+PACKAGE_WRITE_DEPS:append:class-target = " ${MLPREFIX}ptest-runner"
RDEPENDS:${PN}-ptest += "ptest-runner"