summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_5.12.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-06-10 16:31:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-12 22:53:32 +0100
commite1d6e71a54b79b76eb62a6c8da3018b0642967db (patch)
treeaaed49bc18f9eec4776bafb7c13ff051071a5511 /meta/recipes-extended/ethtool/ethtool_5.12.bb
parent798f7c3cf5dcd531d16c426819147656c661dd2e (diff)
downloadopenembedded-core-e1d6e71a54b79b76eb62a6c8da3018b0642967db.tar.gz
ethtool: upgrade 5.10 -> 5.12
refresh avoid_parallel_tests.patch Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_5.12.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_5.12.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_5.12.bb b/meta/recipes-extended/ethtool/ethtool_5.12.bb
new file mode 100644
index 0000000000..df7dd47748
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_5.12.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ "
+
+SRC_URI[sha256sum] = "7ca623cc1dd25ba66531573da6a11f1ecde9b62b00742d9ba54f9ba983439bfa"
+
+UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
+
+inherit autotools ptest bash-completion pkgconfig
+
+RDEPENDS_${PN}-ptest += "make"
+
+PACKAGECONFIG ?= "netlink"
+PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
+ install ${B}/test-features ${D}${PTEST_PATH}
+ fi
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}