summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbsetup_1.0.bb
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2011-05-18 19:12:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-19 23:30:21 +0100
commit08b655196605053740de6a426f6d22561b05c802 (patch)
tree86c98714f11a498b3f0a19bae86ce9c98b44d4d8 /meta/recipes-extended/lsb/lsbsetup_1.0.bb
parent1d4c9412fb8226f882ef68223c9c5ec08cc2f5cc (diff)
downloadopenembedded-core-08b655196605053740de6a426f6d22561b05c802.tar.gz
lsbsetup: Rename this file and add a link for lsb test
[YOCTO #1079] Rename this file version from 0.9 to 1.0. Link time environment for Hong Kong time for lsb test. Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com> Added yocto bugid Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/lsb/lsbsetup_1.0.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbsetup_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsb/lsbsetup_1.0.bb b/meta/recipes-extended/lsb/lsbsetup_1.0.bb
new file mode 100644
index 0000000000..247f9bc736
--- /dev/null
+++ b/meta/recipes-extended/lsb/lsbsetup_1.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "auto-setup environment for lsb test"
+SECTION = "console/utils"
+PRIORITY = "required"
+LICENSE = "GPLv2"
+PR = "r3"
+
+LIC_FILES_CHKSUM = "file://LSB_Setup.sh;beginline=3;endline=16;md5=97451c7c0786ce5bbe9ac58042945583"
+
+SRC_URI = "file://LSB_Setup.sh"
+
+S=${WORKDIR}
+
+do_install() {
+ # Only install file if it has a contents
+ install -d ${D}/usr/bin
+ install -d ${D}/${sysconfdir}
+ install -m 0755 ${S}/LSB_Setup.sh ${D}/usr/bin
+ install -d ${D}/usr/lib/lsb
+ ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/install_initd
+ ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd
+ ln -sf ${sbindir}/sendmail ${D}/${libdir}/sendmail
+ ln -sf ${datadir}/zoneinfo/Asia/Hong_Kong ${D}${sysconfdir}/localtime
+}
+
+FILES_${PN} += "${libdir}/lsb \
+ ${libdir}/* \
+ "