summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/msmtp/msmtp_1.6.6.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-11-28 15:34:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:16 +0000
commit3903eb079d7dc6b67f5c4d4cd15a61eaa8efcfd5 (patch)
tree41e097d14a0b815a1369f7a377fea39b3024e3bc /meta/recipes-extended/msmtp/msmtp_1.6.6.bb
parentf1b59f2dc6bc73cdd2e19f8e82cac1f0d1a7c1e6 (diff)
downloadopenembedded-core-3903eb079d7dc6b67f5c4d4cd15a61eaa8efcfd5.tar.gz
msmtp: update to 1.6.6
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/msmtp/msmtp_1.6.6.bb')
-rw-r--r--meta/recipes-extended/msmtp/msmtp_1.6.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/msmtp/msmtp_1.6.6.bb b/meta/recipes-extended/msmtp/msmtp_1.6.6.bb
new file mode 100644
index 0000000000..e1721936cb
--- /dev/null
+++ b/meta/recipes-extended/msmtp/msmtp_1.6.6.bb
@@ -0,0 +1,30 @@
+SUMMARY = "msmtp is an SMTP client"
+DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
+HOMEPAGE = "http://msmtp.sourceforge.net/"
+SECTION = "console/network"
+
+LICENSE = "GPLv3"
+DEPENDS = "zlib gnutls"
+
+#COPYING or Licence
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.tar.xz \
+ "
+
+SRC_URI[md5sum] = "82b0520b57db4b2cf05333d11fb5974d"
+SRC_URI[sha256sum] = "da15db1f62bd0201fce5310adb89c86188be91cd745b7cb3b62b81a501e7fb5e"
+
+inherit gettext autotools update-alternatives pkgconfig
+
+EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn"
+
+ALTERNATIVE_${PN} = "sendmail"
+ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
+ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
+ALTERNATIVE_PRIORITY = "100"
+
+pkg_postinst_${PN}_linuxstdbase () {
+ # /usr/lib/sendmial is required by LSB core test
+ [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/
+}