summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-09-02 08:22:10 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:53:49 +0100
commit0d7bcdf9fd1bfaebfb5f0b99606e85a8e0229bba (patch)
tree67ef90b98f281032c1e49d7adf0b11e5e9a7889f /meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb
parent36aa00b6f704761b6b518729befc936af674c68d (diff)
downloadopenembedded-core-0d7bcdf9fd1bfaebfb5f0b99606e85a8e0229bba.tar.gz
libmatchbox: Fix the matchbox environment start failure on x86-64 target.
x86 target works well. Root cause is libmatchbox use "0"(int) as termination indicator when calling XftFontOpen, which in turn called FcPatternVapBuild(in fontconfig). It try to get the "0" as char* and fetch wrong value, as int and char* has different size on x86-64. This patch forces a NULL pointer as terminator to fix it. [BUGID #234] is fixed by this Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb')
-rw-r--r--meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb b/meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb
index 1d7d9c8f44..fb554b85f3 100644
--- a/meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb
+++ b/meta/recipes-graphics/libmatchbox/libmatchbox_1.9.bb
@@ -1,11 +1,12 @@
require libmatchbox.inc
-PR = "r7"
+PR = "r8"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/${PV}/${PN}-${PV}.tar.gz \
file://16bppfixes.patch;patch=1 \
file://configure_fixes.patch;patch=1 \
- file://check.m4"
+ file://check.m4 \
+ file://matchbox-start-fix.patch;patch=1"
do_configure_prepend () {
cp ${WORKDIR}/check.m4 ${S}/