summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-10-13 10:41:53 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 12:20:27 +0100
commit3772045d457cb049c34fe3b046cc3a3bb9694c1c (patch)
tree635389e40c7f9e06f7f92f084f540c6ab5a38bbc /meta/recipes-graphics/mesa
parent403a1b0c4bb83165b4c18db42d648e44107ea2ee (diff)
downloadopenembedded-core-3772045d457cb049c34fe3b046cc3a3bb9694c1c.tar.gz
mesa-git: move shared parts from mesa-dri_git to mesa-git.inc and add mesa-xlib_git
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-graphics/mesa')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_git.bb33
-rw-r--r--meta/recipes-graphics/mesa/mesa-git.inc30
-rw-r--r--meta/recipes-graphics/mesa/mesa-xlib_git.bb4
3 files changed, 36 insertions, 31 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_git.bb b/meta/recipes-graphics/mesa/mesa-dri_git.bb
index 14852133ae..9c2c6a1b41 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_git.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_git.bb
@@ -1,36 +1,7 @@
include mesa-common.inc
+include mesa-git.inc
include mesa-dri.inc
-
-SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
- file://cross2.patch \
- file://matypes.h"
-# file://mesa-DRI2Swapbuffer.patch "
-S = "${WORKDIR}/git"
-
-SRCREV = "1bf94d419805538ac23a4d0b04d31ac5e4487aca"
-PV = "7.7+git${SRCPV}"
PR = "${INC_PR}.0"
-PACKAGES =+ "${PN}-xprogs"
-
-FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
-
-do_configure_prepend () {
- cp ${WORKDIR}/matypes.h ${S}/src/mesa/x86
- touch ${S}/src/mesa/x86/matypes.h
-}
-
-do_compile () {
- oe_runmake clean
- oe_runmake -C src/glsl CC='${BUILD_CC}' CFLAGS=""
- mv ${S}/src/glsl/apps/compile ${S}/host_compile
- oe_runmake clean
- oe_runmake GLSL_CL="${S}/host_compile"
-}
-
-do_install_append () {
- install -d ${D}/usr/bin
- install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
-}
-
COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
diff --git a/meta/recipes-graphics/mesa/mesa-git.inc b/meta/recipes-graphics/mesa/mesa-git.inc
new file mode 100644
index 0000000000..2f27ef1a16
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-git.inc
@@ -0,0 +1,30 @@
+SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
+ file://cross2.patch \
+ file://matypes.h"
+# file://mesa-DRI2Swapbuffer.patch "
+S = "${WORKDIR}/git"
+
+SRCREV = "1bf94d419805538ac23a4d0b04d31ac5e4487aca"
+PV = "7.7+git${SRCPV}"
+
+PACKAGES =+ "${PN}-xprogs"
+
+FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
+
+do_configure_prepend () {
+ cp ${WORKDIR}/matypes.h ${S}/src/mesa/x86
+ touch ${S}/src/mesa/x86/matypes.h
+}
+
+do_compile () {
+ oe_runmake clean
+ oe_runmake -C src/glsl CC='${BUILD_CC}' CFLAGS=""
+ mv ${S}/src/glsl/apps/compile ${S}/host_compile
+ oe_runmake clean
+ oe_runmake GLSL_CL="${S}/host_compile"
+}
+
+do_install_append () {
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
+}
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_git.bb b/meta/recipes-graphics/mesa/mesa-xlib_git.bb
new file mode 100644
index 0000000000..7f827a70aa
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-xlib_git.bb
@@ -0,0 +1,4 @@
+include mesa-common.inc
+include mesa-git.inc
+include mesa-xlib.inc
+PR = "${INC_PR}.0"