summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-xserver
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-01 22:50:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-02 15:15:26 +0100
commitf25dd633fffe6560f191526d1869e657e129bad9 (patch)
treed49fa26293f1dca91ca1b00235b19b6579784379 /meta/recipes-graphics/xorg-xserver
parent86fec41b1e809d1a2fa2feadc26d29020df53d39 (diff)
downloadopenembedded-core-f25dd633fffe6560f191526d1869e657e129bad9.tar.gz
recipes: Update S = WORKDIR recipes to use ${S} correctly
Where recipes use S = ${WORKDIR}, ensure they are referencing ${S} correctly to access files as soon we want to stop doing this in WORKDIR at which point they would break unless corrected. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-xserver')
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
index 03f14cef2b..a3a4733785 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
@@ -14,8 +14,8 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
ALLOW_EMPTY:${PN} = "1"
do_install () {
- if test -s ${WORKDIR}/xorg.conf; then
+ if test -s ${S}/xorg.conf; then
install -d ${D}/${sysconfdir}/X11
- install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+ install -m 0644 ${S}/xorg.conf ${D}/${sysconfdir}/X11/
fi
}