summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-08-08 08:42:06 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-10 08:20:13 +0100
commit1cf79df7dd14c0bfa87364ff28fffb61e7c560fa (patch)
tree12dc3b1a969bb9010b983c302c392dbbe6dc2c0f /meta/recipes-graphics
parent00c40d1343dd34a416657b79745f102a17332ddb (diff)
downloadopenembedded-core-1cf79df7dd14c0bfa87364ff28fffb61e7c560fa.tar.gz
harfbuzz: upgrade 4.4.1 -> 5.1.0
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz/0001-fix-signedness-of-char-in-tests.patch27
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb (renamed from meta/recipes-graphics/harfbuzz/harfbuzz_4.4.1.bb)6
2 files changed, 31 insertions, 2 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz/0001-fix-signedness-of-char-in-tests.patch b/meta/recipes-graphics/harfbuzz/harfbuzz/0001-fix-signedness-of-char-in-tests.patch
new file mode 100644
index 0000000000..029ca2bfff
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz/0001-fix-signedness-of-char-in-tests.patch
@@ -0,0 +1,27 @@
+From 1bd3884bc0544ffbb6545ed2391f0932bb8d7d91 Mon Sep 17 00:00:00 2001
+From: psykose <alice@ayaya.dev>
+Date: Mon, 1 Aug 2022 07:45:25 +0000
+Subject: [PATCH] fix signedness of char in tests
+
+Upstream-Status: Backport
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ src/test-repacker.cc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/test-repacker.cc b/src/test-repacker.cc
+index 053c0c6..1b7e1f0 100644
+--- a/src/test-repacker.cc
++++ b/src/test-repacker.cc
+@@ -112,9 +112,9 @@ static void start_lookup (int8_t type,
+ hb_serialize_context_t* c)
+ {
+ char lookup[] = {
+- 0, type, // type
++ 0, (char)type, // type
+ 0, 0, // flag
+- 0, num_subtables, // num subtables
++ 0, (char)num_subtables, // num subtables
+ };
+
+ start_object (lookup, 6, c);
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_4.4.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
index c2867d2a9f..4c2d774803 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_4.4.1.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
@@ -11,8 +11,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6ee0f16281694fb6aa689cca1e0fb3da \
UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
-SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz"
-SRC_URI[sha256sum] = "c5bc33ac099b2e52f01d27cde21cee4281b9d5bfec7684135e268512478bc9ee"
+SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz \
+ file://0001-fix-signedness-of-char-in-tests.patch \
+ "
+SRC_URI[sha256sum] = "2edb95db668781aaa8d60959d21be2ff80085f31b12053cdd660d9a50ce84f05"
inherit meson pkgconfig lib_package gtk-doc gobject-introspection