summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorPetr Kubizňák <kubiznak@2n.com>2023-01-04 12:45:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-12 23:07:39 +0000
commit21261072cbe0056e85550a0710de142fab8943e4 (patch)
treed9018540b08aabc9bfb09cefe84a132fc6f56239 /meta/recipes-graphics
parent4a34adad4efbb442aebf25c42d897339c293ef0f (diff)
downloadopenembedded-core-21261072cbe0056e85550a0710de142fab8943e4.tar.gz
harfbuzz: remove bindir only if it exists
In some scenarios (e.g. when "glib" removed from PACKAGECONFIG), "${D}${bindir}" might not exist which caused `rmdir` to fail. Signed-off-by: Petr Kubizňák <kubiznak@2n.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb
index 46ab6a4ca8..ae54bad643 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb
@@ -30,9 +30,9 @@ PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
LEAD_SONAME = "libharfbuzz.so"
do_install:append() {
- # If no tools are installed due to PACKAGECONFIG then this directory is
- #still installed, so remove it to stop packaging wanings.
- rmdir --ignore-fail-on-non-empty ${D}${bindir}
+ # If no tools are installed due to PACKAGECONFIG then this directory might
+ # still be installed, so remove it to stop packaging warnings.
+ [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir}
}
FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"