summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2010-11-24 12:51:42 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-02 05:24:57 -0800
commit742f217ac29577194fcdaec61117e04d26213220 (patch)
tree93748ec0576bdc9f219b3c91c74c2fd9baeff85e /meta/recipes-graphics
parent2e95941ef0cc1638f3e4774256a736f3996f63fa (diff)
downloadopenembedded-core-742f217ac29577194fcdaec61117e04d26213220.tar.gz
mesa-dri: upgrade from 7.8.2 to 7.9
with the following changes: - remove mesa-demos, because starting from mesa 7.9, mesa-demos becomes a standalone src tar ball in upstream, so there will be a seperate recipes to build the mesa-demos - add dependency of talloc and libxml2-native Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.9.bb (renamed from meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb)25
1 files changed, 5 insertions, 20 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb b/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
index caa9b2ecbc..6f0f984022 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
@@ -3,13 +3,15 @@ include mesa-common.inc
LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
PROTO_DEPS = "xf86driproto glproto dri2proto"
-LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
+LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
+ libxml2-native talloc"
DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} mesa-dri-glsl-native"
-PR = "r2"
+PR = "r0"
-SRC_URI += "file://crossfix.patch"
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+ file://crossfix.patch"
# most of our targets do not have DRI so will use mesa-xlib
DEFAULT_PREFERENCE = "-1"
@@ -21,16 +23,6 @@ LEAD_SONAME = "libGL.so.1"
EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
-# We need glsl-compile built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
-do_configure_prepend() {
- sed -i "s#^GLSL_CL = .*\$#GLSL_CL = ${STAGING_BINDIR_NATIVE}/glsl-compile#g" ${S}/src/mesa/shader/slang/library/Makefile
-}
-
-do_install_append () {
- install -d ${D}/usr/bin
- install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
-}
-
python populate_packages_prepend() {
import os.path
@@ -41,13 +33,6 @@ python populate_packages_prepend() {
COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
-PACKAGES =+ "${PN}-xprogs"
PACKAGES_DYNAMIC = "mesa-dri-driver-*"
FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
-FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
-
-#
-# Header generated by i586-poky-linux-gcc gen_matypes.c -o gen_matypes -I ../../../include/GL -I ../../../include -I .. -I ../main/ -I ../math -I ../glapi/ -I ../tnl
-# then run gen_matypes > matypes.h on device
-#