summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2010-11-28 10:10:07 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-02 05:24:58 -0800
commita3a4960122359ab0642f0d93c7725b414beb4a2f (patch)
tree560b605f7bf59237aebac4b77ea1fa8d18d5b0d2 /meta/recipes-graphics
parent5358036d5f47f3211dbc51dc5a408b316c4e4963 (diff)
downloadopenembedded-core-a3a4960122359ab0642f0d93c7725b414beb4a2f.tar.gz
mesa-dri-glsl-native: upgrade from 7.8.2 to 7.9
with the following changes - add license checksum - add dependency of talloc-native, because mesa 7.9 start to use talloc to manage its memory. Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb (renamed from meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb)9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb
index f6121c19a4..ffc113bfa7 100644
--- a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb
@@ -3,22 +3,23 @@ HOMEPAGE = "http://mesa3d.org"
BUGTRACKER = "https://bugs.freedesktop.org"
SECTION = "x11"
LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://main.cpp;endline=22;md5=a12a9c0208ee64a07ce314dfed4c81eb"
PR = "r0"
-DEPENDS = "makedepend-native"
+DEPENDS = "makedepend-native talloc-native"
SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
-S = "${WORKDIR}/Mesa-7.8.2/src/glsl/"
+S = "${WORKDIR}/Mesa-${PV}/src/glsl"
inherit native
# use default config for native build
do_configure_prepend() {
- ln -s ${S}/../../configs/default ${S}/../../configs/current
+ ln -sf ${S}/../../configs/default ${S}/../../configs/current
}
do_install() {
install -d ${D}/${bindir}
- install -m 755 ${S}/apps/compile ${D}/${bindir}/glsl-compile
+ install -m 755 ${S}/glsl_compiler ${D}/${bindir}/
}