summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bash-completion/bash-completion_2.9.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-05-20 16:11:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-22 07:24:38 +0100
commit9f9846d975ca9cc863e1510e47a2d2ebb5573302 (patch)
tree4631f38c7628988fa902758bf517a8c7b116d8ff /meta/recipes-support/bash-completion/bash-completion_2.9.bb
parent414231e9cd75e4d845997b2c5d17d350034747b3 (diff)
downloadopenembedded-core-9f9846d975ca9cc863e1510e47a2d2ebb5573302.tar.gz
bash-completion: upgrade 2.8 -> 2.9
Delete the deletion of files, as they are no longer included in bash-completion (util-linux provides them). Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/bash-completion/bash-completion_2.9.bb')
-rw-r--r--meta/recipes-support/bash-completion/bash-completion_2.9.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-support/bash-completion/bash-completion_2.9.bb b/meta/recipes-support/bash-completion/bash-completion_2.9.bb
new file mode 100644
index 0000000000..cd2c4cbba8
--- /dev/null
+++ b/meta/recipes-support/bash-completion/bash-completion_2.9.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Programmable Completion for Bash 4"
+HOMEPAGE = "http://bash-completion.alioth.debian.org/"
+BUGTRACKER = "https://alioth.debian.org/projects/bash-completion/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SECTION = "console/utils"
+
+SRC_URI = "https://github.com/scop/bash-completion/releases/download/${PV}/${BPN}-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "60139333b25c4d54ad40323b701be130"
+SRC_URI[sha256sum] = "d48fe378e731062f479c5f8802ffa9d3c40a275a19e6e0f6f6cc4b90fa12b2f5"
+UPSTREAM_CHECK_REGEX = "bash-completion-(?P<pver>(?!2008).+)\.tar"
+UPSTREAM_CHECK_URI = "https://github.com/scop/bash-completion/releases"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+do_install_append() {
+ # compatdir
+ install -d ${D}${sysconfdir}/bash_completion.d/
+ echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
+
+}
+
+RDEPENDS_${PN} = "bash"
+
+# Some recipes are providing ${PN}-bash-completion packages
+PACKAGES =+ "${PN}-extra"
+FILES_${PN}-extra = "${datadir}/${BPN}/completions/ \
+ ${datadir}/${BPN}/helpers/"
+
+FILES_${PN}-dev += "${datadir}/cmake"
+
+BBCLASSEXTEND = "nativesdk"