summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/consolekit/consolekit
diff options
context:
space:
mode:
authorYasir-Khan <yasir_khan@mentor.com>2014-08-13 18:48:13 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-15 18:19:53 +0100
commit66d53c40f1eb614803a34dfa3741b170785c637d (patch)
treeac1489aeb269ac1402a734aef8455c44804c195e /meta/recipes-support/consolekit/consolekit
parent140d188b3665f914396834168feeff6ffcb64d76 (diff)
downloadopenembedded-core-66d53c40f1eb614803a34dfa3741b170785c637d.tar.gz
consolekit: allow explicit enable/disable of polkit
Adds the configure option to enable/disable policykit. Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Yasir-Khan <yasir_khan@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/consolekit/consolekit')
-rw-r--r--meta/recipes-support/consolekit/consolekit/add-polkit-configure-argument.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-support/consolekit/consolekit/add-polkit-configure-argument.patch b/meta/recipes-support/consolekit/consolekit/add-polkit-configure-argument.patch
new file mode 100644
index 0000000000..ad879d466b
--- /dev/null
+++ b/meta/recipes-support/consolekit/consolekit/add-polkit-configure-argument.patch
@@ -0,0 +1,33 @@
+Upstream-Status: Pending
+
+--- ConsoleKit-0.4.6.orig/configure.ac
++++ ConsoleKit-0.4.6/configure.ac
+@@ -56,10 +56,24 @@ PKG_CHECK_MODULES(CONSOLE_KIT,
+ gthread-2.0 >= $GLIB_REQUIRED_VERSION
+ )
+
+-PKG_CHECK_MODULES(POLKIT,
+- polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
+- have_polkit=yes,
+- have_polkit=no)
++AC_ARG_WITH([polkit],
++ [AS_HELP_STRING([--with-polkit],
++ [support PolicyKit @<:@default=check@:>@])],
++ [],
++ [with_polkit=check])
++
++AS_IF([test "x$with_polkit" != xno],
++ [PKG_CHECK_MODULES(POLKIT,
++ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
++ have_polkit=yes,
++ [if test "x$with_polkit" != xcheck; then
++ AC_MSG_FAILURE(
++ [--with-polkit was given, but test for polkit failed])
++ else
++ have_polkit=no
++ fi
++ ])])
++
+ if test "x$have_polkit" = "xyes" ; then
+ AC_DEFINE(HAVE_POLKIT, [], [Define if we have polkit])
+ fi