summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/diffoscope/diffoscope_164.bb
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2021-01-15 07:54:54 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-16 22:39:17 +0000
commit65feaffe9857029fa230935cb0c3e8e6f2815776 (patch)
tree41ac5fee5ed216b24d00e378444505f68e989c10 /meta/recipes-support/diffoscope/diffoscope_164.bb
parent2f790ded554a52ac18d1c28002142f9c62abec8b (diff)
downloadopenembedded-core-65feaffe9857029fa230935cb0c3e8e6f2815776.tar.gz
diffoscope: upgrade 163 -> 164
[ Chris Lamb ] * Truncate jsondiff differences at 512 bytes lest they consume the entire page. * Wrap our external call to cmp(1) with a profile (to match the internal profiling). * Add a note regarding the specific ordering of the new all_tools_are_listed test. [ Dimitrios Apostolou ] * Performance improvements: - Improve speed of has_same_content by spawning cmp(1) less frequently. - Log whenever the external cmp(1) command is spawn.ed - Avoid invoking external diff for identical, short outputs. * Rework handling of temporary files: - Clean up temporary directories as we go along, instead of at the end. - Delete FIFO files when the FIFO feeder's context manager exits. [ Mattia Rizzolo ] * Fix a number of potential crashes in --list-debian-substvars, including explicitly listing lipo and otool as external tools. - Remove redundant code and let object destructors clean up after themselves. [ Conrad Ratschan ] * Add a comparator for Flattened Image Trees (FIT) files, a boot image format used by U-Boot. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/diffoscope/diffoscope_164.bb')
-rw-r--r--meta/recipes-support/diffoscope/diffoscope_164.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-support/diffoscope/diffoscope_164.bb b/meta/recipes-support/diffoscope/diffoscope_164.bb
new file mode 100644
index 0000000000..7707c441ca
--- /dev/null
+++ b/meta/recipes-support/diffoscope/diffoscope_164.bb
@@ -0,0 +1,17 @@
+SUMMARY = "in-depth comparison of files, archives, and directories"
+HOMEPAGE = "https://diffoscope.org/"
+LICENSE = "GPL-3.0+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+PYPI_PACKAGE = "diffoscope"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "bc269a39ec72261d9fead55bd951f6cbbe3d2ccce1481f974665999a5b141fff"
+
+RDEPENDS_${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic"
+
+# Dependencies don't build for musl
+COMPATIBLE_HOST_libc-musl = 'null'
+
+BBCLASSEXTEND = "native"