summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-12-01 10:33:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-04 12:45:20 +0000
commitd2c4e8cb85c6a5ca37c7990f879c3b650df5770b (patch)
tree0c02a182e9c2157cea363ccaa02089fafdd5b5c6 /meta/recipes-support/vte
parente3cd856f1ef66aefe2f5f6f1e7771376616d721a (diff)
downloadopenembedded-core-d2c4e8cb85c6a5ca37c7990f879c3b650df5770b.tar.gz
vte: Separate out gtk4 pieces of vte into individual packages
This avoids adding gtk4 dependencies when image may only desire the gtk3 pieces of vte. Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vte')
-rw-r--r--meta/recipes-support/vte/vte_0.74.1.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-support/vte/vte_0.74.1.bb b/meta/recipes-support/vte/vte_0.74.1.bb
index 8a7054a13c..071f668464 100644
--- a/meta/recipes-support/vte/vte_0.74.1.bb
+++ b/meta/recipes-support/vte/vte_0.74.1.bb
@@ -36,7 +36,16 @@ PACKAGECONFIG[gtk4] = "-Dgtk4=true,-Dgtk4=false,gtk4"
PACKAGECONFIG[gnutls] = "-Dgnutls=true,-Dgnutls=false,gnutls"
PACKAGECONFIG[systemd] = "-D_systemd=true,-D_systemd=false,systemd"
-PACKAGES =+ "libvte ${PN}-prompt"
+PACKAGES =+ "libvte-gtk4 ${PN}-gtk4 ${PN}-gtk4-dev libvte ${PN}-prompt"
+FILES:libvte-gtk4 = "${libdir}/lib*gtk4.so.* ${libdir}/girepository-1.0/Vte-3.91.typelib"
+FILES:${PN}-gtk4 ="${bindir}/vte-2.91-gtk4"
+FILES:${PN}-gtk4-dev = "${libdir}/lib*gtk4.so \
+ ${libdir}/pkgconfig/vte-2.91-gtk4.pc \
+ ${datadir}/gir-1.0/Vte-3.91.gir \
+ ${datadir}/vala/vapi/vte-2.91-gtk4.deps \
+ ${datadir}/vala/vapi/vte-2.91-gtk4.vapi \
+ ${includedir}/vte-2.91-gtk4 \
+ "
FILES:${PN} +="${systemd_user_unitdir}"
FILES:libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*"
FILES:${PN}-prompt = " \