summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-26 13:46:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-31 17:09:45 +0000
commit22f639d61127f4b82a79008c5305e44e090a3680 (patch)
tree6e2cd49c5e03342a1553154db7642320522819cb /meta
parent2e9989a8f8b5b93476e551475df010add32aac31 (diff)
downloadopenembedded-core-22f639d61127f4b82a79008c5305e44e090a3680.tar.gz
busybox: Make provisions to disable sha256/sha1 accelaration on x86
busybox 1.36 has an ongoing regression on musl/i386 [1] we see same on glibc systems too. therefore avoid the affected code by disabling sha256/sha1 sum accelaration meanwhile CONFIG_SHA256_HWACCEL and CONFIG_SHA1_HWACCEL are enabled by default [1] http://lists.busybox.net/pipermail/busybox/2023-January/090078.html Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/busybox/busybox/sha1sum.cfg1
-rw-r--r--meta/recipes-core/busybox/busybox/sha256sum.cfg1
-rw-r--r--meta/recipes-core/busybox/busybox/sha_accel.cfg2
-rw-r--r--meta/recipes-core/busybox/busybox_1.36.0.bb3
4 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-core/busybox/busybox/sha1sum.cfg b/meta/recipes-core/busybox/busybox/sha1sum.cfg
index 01137a2486..afd4da4ea1 100644
--- a/meta/recipes-core/busybox/busybox/sha1sum.cfg
+++ b/meta/recipes-core/busybox/busybox/sha1sum.cfg
@@ -1,3 +1,2 @@
CONFIG_SHA1SUM=y
CONFIG_SHA1_SMALL=3
-CONFIG_SHA1_HWACCEL=y
diff --git a/meta/recipes-core/busybox/busybox/sha256sum.cfg b/meta/recipes-core/busybox/busybox/sha256sum.cfg
index a5b0ab22d1..ce652ae4c6 100644
--- a/meta/recipes-core/busybox/busybox/sha256sum.cfg
+++ b/meta/recipes-core/busybox/busybox/sha256sum.cfg
@@ -1,2 +1 @@
CONFIG_SHA256SUM=y
-CONFIG_SHA256_HWACCEL=y
diff --git a/meta/recipes-core/busybox/busybox/sha_accel.cfg b/meta/recipes-core/busybox/busybox/sha_accel.cfg
new file mode 100644
index 0000000000..8900305a11
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/sha_accel.cfg
@@ -0,0 +1,2 @@
+# CONFIG_SHA256_HWACCEL is not set
+# CONFIG_SHA1_HWACCEL is not set
diff --git a/meta/recipes-core/busybox/busybox_1.36.0.bb b/meta/recipes-core/busybox/busybox_1.36.0.bb
index e46d43e681..8014a5c7bf 100644
--- a/meta/recipes-core/busybox/busybox_1.36.0.bb
+++ b/meta/recipes-core/busybox/busybox_1.36.0.bb
@@ -51,5 +51,6 @@ SRC_URI = "https://busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://0002-nslookup-sanitize-all-printed-strings-with-printable.patch \
"
SRC_URI:append:libc-musl = " file://musl.cfg "
-
+# TODO http://lists.busybox.net/pipermail/busybox/2023-January/090078.html
+SRC_URI:append:x86 = " file://sha_accel.cfg"
SRC_URI[tarball.sha256sum] = "542750c8af7cb2630e201780b4f99f3dcceeb06f505b479ec68241c1e6af61a5"